收藏
回答

web-view已经配置了业务域名,地址指向的是https,为什么提示不支持打开非业务域名http?

回答关注问题邀请回答
收藏

4 个回答

  • Admin²⁰²¹
    Admin²⁰²¹
    2020-08-18

    测试发现,这个页面会get一个http的首页index.html

    请检查源h5页面相关代码,去掉get一个http的操作代码即可

    2020-08-18
    有用 1
    回复 5
    • 归去来兮
      归去来兮
      2020-08-18
      我这边好像没有看到,你打开的是上面发的那个链接么
      2020-08-18
      回复
    • Admin²⁰²¹
      Admin²⁰²¹
      2020-08-18回复归去来兮
      这个页面正常,注册登陆进去后,点首页你能看到
      2020-08-18
      回复
    • 归去来兮
      归去来兮
      2020-08-18回复Admin²⁰²¹
      嗯嗯,看到了,这个页面我现在都进不去,不知道是不是这个引起的
      2020-08-18
      回复
    • Admin²⁰²¹
      Admin²⁰²¹
      2020-08-18回复归去来兮
      这个肯定会引起报http错误了。因为请求了非业务域名了,不报错才怪
      2020-08-18
      回复
    • 归去来兮
      归去来兮
      2020-08-18回复Admin²⁰²¹
      是的,感谢,已解决
      2020-08-18
      回复
  • 默垂眸
    默垂眸
    2020-12-17

    兄弟 你这个也只是ios有问题吗?

    我的配置地址、指向地址 都是一样的 。只有ios用户打不开会提示http非业务域名

    安卓用户可以正常打开

    2020-12-17
    有用
    回复 2
    • Yuan
      Yuan
      2020-12-30
      我们情况跟你一模一样,你现在有解决方案吗
      2020-12-30
      回复
    • 默垂眸
      默垂眸
      2020-12-30回复Yuan
      暂时还未找到好的解决方案
      暂时处理方案:  校验webview跳转的地址 如果是https的就直接跳转  如果是http的就出个弹框 提示用户复制链接,浏览器打开
      2020-12-30
      回复
  • จุ๊บ
    จุ๊บ
    2020-08-18

    实际测试代码片段 正常跳转https,但是因为测试号没有配置web-view导致无法正常跳转。

    2020-08-18
    有用
    回复 3
    • 归去来兮
      归去来兮
      2020-08-18
      在开发环境下是已经配置过的
      2020-08-18
      回复
    • จุ๊บ
      จุ๊บ
      2020-08-18回复归去来兮
      开发工具中这个配置是否显示正常,或者清空所有缓存试下
      2020-08-18
      回复
    • 归去来兮
      归去来兮
      2020-08-18回复จุ๊บ
      试了,还是不行
      2020-08-18
      回复
  • 青寒
    青寒
    2020-08-18

    http和https是不同的地址。

    2020-08-18
    有用
    回复 1
    • 归去来兮
      归去来兮
      2020-08-18
      配置就是https,指向的地址也是https
      2020-08-18
      回复
登录 后发表内容
问题标签