收藏
回答

navigator跳转小程序问题

问题模块 框架类型 问题类型 API/组件名称 终端类型 操作系统 微信版本 基础库版本
API和组件 小程序 Bug navigator 客户端 Android 6.6.7 1.9.97

目前navigator这个组件跳转小程序的限制是2.0.7的基础库版本才可以,现在用三星的一个Android手机,升级到最新的微信版本,基础库版本也只是1.9.97,这种情况怎么跳转小程序?

最后一次编辑于  2018-07-10  (未经腾讯允许,不得转载)
邀请回答
复制链接收藏投诉关注问题回答

3 个回答

  • 土豆豆
    土豆豆
    2018-07-10

    自己顶一下,官方出来解答下   原接口不能用,新接口基础库又不够,是要断了开发者的活路吗?

    2018-07-10
    赞同
    回复 12
    • 是柿子啊
      是柿子啊
      2018-07-10

      https://developers.weixin.qq.com/miniprogram/dev/component/navigator.html,这是文档链接,你看下

      2018-07-10
      回复
    • 土豆豆
      土豆豆
      2018-07-10回复是柿子啊

      现在是基础库太低,无法使用这个,微信都升级到最新版本了,基础库还是1.9.97,是用这种方式跳转不了的

      2018-07-10
      回复
    • 是柿子啊
      是柿子啊
      2018-07-10回复土豆豆

      navigator跳转小程序基础库必须要2.0.7才支持,建议你升级一下

      2018-07-10
      回复
    • 土豆豆
      土豆豆
      2018-07-10回复是柿子啊

      微信已经升级到最新的版本6.6.7,调试里看到的基础库版本还是1.9.97

      2018-07-10
      回复
    • 是柿子啊
      是柿子啊
      2018-07-10回复土豆豆


      你试试改一下这里

      2018-07-10
      回复
    查看更多(7)
  • 小西
    小西
    2018-07-10

    换成api-wx.navigateTo试试

     


    2018-07-10
    赞同
    回复 1
    • 土豆豆
      土豆豆
      2018-07-10

      我知道原来的那个接口可能可以使用,但现在官方给出的公告要废弃那个接口,现在去用了,线上哪天它给禁用了,那就成线上事故了....

      2018-07-10
      回复
  • 远航²º¹⁹
    远航²º¹⁹
    2018-07-12

    还有用这个navigator跳转的话,就监听不到是否跳转成功了


    2018-07-12
    赞同
    回复 1
    • 土豆豆
      土豆豆
      2018-07-12

      我现在是这样的,一进来拿一下基础库版本号,大于2.0.7,显示navigator组件,小于的话显示一个view,view上面绑定个事件,用跳转小程序的api跳转,这样的话,即使版本库低的时候会拿旧接口尝试下跳转,跳不了也可以在fail里面监听到


      你可以这么理解,大于2.0.7的基础库用组件肯定可以跳转成功,小于的用组件肯定跳转不成功

      2018-07-12
      回复