收藏
回答

canvasContext.clip在最新的基础库2.7.3兼容性有问题

问题模块 框架类型 问题类型 API/组件名称 终端类型 微信版本 基础库版本
API和组件 小程序 Bug canvasContext.clip 客户端 7.0.4 2.7.3

- 当前 Bug 的表现(可附上截图)



- 预期表现


可以生成完整的海报


- 复现路径


- 提供一个最简复现 Demo


https://developers.weixin.qq.com/s/Iu64Prmx7E9z


wx.canIUse('canvasContext.clip')  在小程序基础库2.7.3 返回false 华为mate20(实测) pro  nova2   / oppo r15 /8p  iphone xr   等都有问题.

最后一次编辑于  06-27
回答关注问题邀请回答
收藏

1 个回答

  • 社区技术运营专员-灵芝
    社区技术运营专员-灵芝
    06-27

    这里需要写wx.canIUse('CanvasContext.clip')

    06-27
    赞同
    回复 3
    • 小野猫
      小野猫
      06-27

      写过了呀,我的代码是这样的

      if (!wx.canIUse('canvasContext.clip')) {

      return Promise.reject({ errorText: '海报生成失败\r\n微信客户端版本过低,请升级' });

      }


      06-27
      回复
    • 社区技术运营专员-灵芝
      社区技术运营专员-灵芝
      06-27回复小野猫

      CanvasContext 首字母大写哈

      06-27
      回复
    • 小野猫
      小野猫
      06-27回复社区技术运营专员-灵芝

      好的,我去试试,谢谢您

      06-27
      回复