收藏
回答

为什么会出现分包页面onPageNotFound?

小程序正式版,部分用户跳转分包页面时,为空白页,通过错误日志查看,发现报错onPageNotFound。

什么情况会出现这种情况。

回答关注问题邀请回答
收藏

2 个回答

  • 社区技术运营专员-CJiang
    社区技术运营专员-CJiang
    08-25

    麻烦提供能复现问题的简单代码片段(https://developers.weixin.qq.com/miniprogram/dev/devtools/minicode.html)。

    08-25
    有用
    回复 3
    • Vince
      Vince
      08-25
      没有代码片段,目前从反馈的情况看,大部分是苹果手机会出现问题
      08-25
      回复
    • Vince
      Vince
      08-25
      提示has not bean registered yet,但是大部分又是正常的
      08-25
      回复
    • 社区技术运营专员-CJiang
      社区技术运营专员-CJiang
      08-26回复Vince
      麻烦提供下appid。复现的手机机型、微信版本号。
      08-26
      回复
  • 哈皮榴莲 。
    哈皮榴莲 。
    10-14

    我也遇到了同样的情况,在使用分包的情况下,跳转分包下的页面时,无法跳转,走了系统onPageNotFound的回调,

    这是实时日志的打印内容,

    [10:02:21]  App onPageNotFound {"path":"packagesHome/pages/index/index","rawPath":"packagesHome/pages/index/index.html","qualityData":{"isWebviewPreload":true,"navId":"-1139044571_1602640940170","isPreloadPageFrame":true},"preloadRule":null,"query":{},"resizing":false,"notFound":true,"page":{"window":{"navigationBarBackgroundColor":"#ffff","usingComponents":{"header-view":"../../components/header-view/index","header-title":"../../components/header-title/index","week-plan":"../../components/week-plan/index","banner-view":"../../components/banner-view/index","weather":"../../components/weather/index","purchase-order":"../../components/purchase-order/index","goods-statistics":"../../components/goods-statistics/index","recommend-goods":"../../components/recommend-goods/index","history-order":"../../components/history-order/index","van-icon":"/miniprogram/miniprogram_npm/@vant/weapp/icon/index","van-row":"/miniprogram/miniprogram_npm/@vant/weapp/row/index","van-col":"/miniprogram/miniprogram_npm/@vant/weapp/col/index","van-overlay":"/miniprogram/miniprogram_npm/@vant/weapp/overlay/index","custom-page":"/components/custom-page/index","van-popup":"/miniprogram/miniprogram_npm/@vant/weapp/popup/index"}}},"prerender":false,"openType":"navigateTo"}


    以下是做的分包设置,


    明明在分包中有对应的页面,但是还是会出现onPageNotFound的回调,无法正确跳转,因为还未发布过正式版,这样的情况只在体验版中出现过,而且还是偶发性的,删除重新加载小程序的时候,有的时候就会正常跳转了,

    10-14
    有用
    回复
登录 后发表内容
问题标签