收藏
回答

代码保护问题

问题模块 框架类型 问题类型 操作系统 工具版本
开发者工具 小程序 Bug Windows v1.02.1905092


代码保护

开启此选项,开发者工具会尝试对项目代码进行保护,主要是对文件进行扁平化处理并替换 require 引用的文件名,以下情况不适合使用此功能

  1. 对于小程序只有简单页面的情况下,开启此功能效果不佳

  2. 有文件超过 500kb,且其中有使用 require 引用项目中的文件的情况,在运行时可能会报文件没有找到

  3. 动态引用的情况,如 var a = 'somefile.js'; require(a);

  4. 将 require 函数赋值给其他变量的情况,如 var a = require; a('somefile.js');

  5. 将 require 作为二元运算符的参数的情况,如 require + 1;

  6. 使用 ... 运算符且未开启 ES6 转 ES5 的情况


注:这个问题有点莫名其妙了,望工程师尽快回复一下怎么解决这个问题

最后一次编辑于  05-15  (未经腾讯允许,不得转载)
邀请回答
复制链接收藏投诉关注问题回答

1 个回答

  • RedHood
    RedHood
    05-15

    第 3 点写了,不支持动态引用的情况。 require("utils/" + e + ".js"); 也是属于动态引用的情况。

    05-15
    赞同
    回复 5
    • Dark Sunny
      Dark Sunny
      05-15

      不懂为什么新版本要加这个机制,影响框架开发

      05-15
      回复
    • RedHood
      RedHood
      05-15回复Dark Sunny

      你可以把代码保护勾选掉。。

      05-15
      回复
    • Dark Sunny
      Dark Sunny
      05-15

      这个完全没必要,这哪里是代码保护,这就是故意设障碍,好好的项目被搞崩,要改几百行代码,小程序不是轻量级吗?想起一出是一出,烦

      05-15
      回复
    • RedHood
      RedHood
      05-15回复Dark Sunny

      你直接勾选关掉就行了啊

      05-15
      回复
    • Dark Sunny
      Dark Sunny
      05-15回复RedHood

      。。。。。。。没注意到,可以了

      05-15
      回复