收藏
回答

小程序端打开会员卡组件后组件一直提示参数错误

小程序端打开会员卡组件后组件一直提示参数错误,

这个参数错误具体是指哪里的参数错误呢,

是接口1中的开卡插件参数错误呢还是本身会员卡创建的时候的参数错误呢

最后一次编辑于  2018-01-09
回答关注问题邀请回答
收藏

17 个回答

  • 三月
    三月
    01-15

    参数错误+1

    01-15
    赞同
    回复
  • 恒恒Daddy
    恒恒Daddy
    01-04

    你好,我在调用开卡组件时,传的encrypt_card_id, biz已urldecode,请问biz后面的#wechat_redirect是需要删除吗,谢谢?

    01-04
    赞同
    回复
  • 董海军 |婴泳管|软件研发负责人
    董海军 |婴泳管|软件研发负责人
    2018-02-14

    我的程序执行这个提示“navigateToMiniProgram:fail can't navigate to myself"

    这是怎么回事呢,难道不是在小程序内部调用appid等于当前小程序的吗?

    2018-02-14
    赞同
    回复
  • 天赐Di
    天赐Di
    2018-01-12

    哎,对了。麻烦问下,你用API创建会员卡,就只用了一步对吗?就是直接调用了

    https://api.weixin.qq.com/card/create?access_token=$access_token

    就ok了吧?

    2018-01-12
    赞同
    回复
  • 天赐Di
    天赐Di
    2018-01-12

    好吧

    2018-01-12
    赞同
    回复
  • 佳良
    佳良
    2018-01-12

    这个倒没有碰到过

    2018-01-12
    赞同
    回复
  • 天赐Di
    天赐Di
    2018-01-12

    你好,请问你有没有碰上跳转成功后点击立即开卡显示请输入验证码


    2018-01-12
    赞同
    回复 1
    • Rambo
      Rambo
      2018-08-29

      你好,我这边三个参数都获取到了

           encrypt_card_id:'qxwfuv8cJdcZRLQ8u+Bprbq3qCqSlKd5S4MeJW1bFl2pinr0+FdjXyuePIYRKreg',

           outer_str:'123',

           biz:'MzUyMDUyMDIyMw==#'

      ,调用

      <navigator target="miniProgram" app-id="w*****" extra-data="{{dataa}}" >会员卡开卡</navigator>


      组件,然后测试的时候点击《会员卡开卡》时候没反应的?也没报错?请问是什么原因呢

      2018-08-29
      回复
  • 佳良
    佳良
    2018-01-10

    确实如此,多谢指导

    2018-01-10
    赞同
    回复
  • 佳良
    佳良
    2018-01-10

    确定吗,我试试

    2018-01-10
    赞同
    回复
  • FourierWang(王立强)
    FourierWang(王立强)
    2018-01-10

    你好,biz后面的#wechat_redirect去掉,另外参数应该要先urldecode

    2018-01-10
    赞同
    回复

正在加载...