收藏
回答

map已经支持同层渲染了?

问题模块 框架类型 问题类型 API/组件名称 终端类型 微信版本 基础库版本
API和组件 小程序 Bug map 客户端 7.0.5 2.7.7



根据这位官方大大的回答map组件已经支持同层渲染了!可是为什么我2.7.7的版本还是不能控制map层级???


最后一次编辑于  2019-07-25
回答关注问题邀请回答
收藏

3 个回答

  • 社区技术运营专员-娇华
    社区技术运营专员-娇华
    2019-07-25

    你好,map在2.7.0已经支持同层,可以用 z-index 控制层级,若有问题,麻烦提供出现问题的具体机型、微信版本号、系统版本号,以及能复现问题的代码片段(https://developers.weixin.qq.com/miniprogram/dev/devtools/minicode.html

    2019-07-25
    赞同
    回复 12
    • 微云
      微云
      2019-07-25
      我严重怀疑你记错了!我试了身边所有同事的手机都不行。版本是7.0.5,基础库是2.7.7!代码片段:https://developers.weixin.qq.com/s/yc0CC8mu7Ral
      2019-07-25
      回复
    • 微云
      微云
      2019-07-26
      能给个准信吗?我们业务逻辑需要在地图上做,迫切需要map同层啊!!
      2019-07-26
      回复
    • 社区技术运营专员-娇华
      社区技术运营专员-娇华
      2019-07-26回复微云

      第一张图,我是直接预览的你的代码片段,这里你控制的是view的层级,有效

      第二张图,我控制map的层级,有效
      所以你这边要具体复现问题表现,预期效果如何,具体未达到预期效果的机型、系统版本、微信版本、基础库版本,这里具体核实下,然后提供。

      2019-07-26
      回复
    • 微云
      微云
      2019-07-26回复社区技术运营专员-娇华


      这是我的,一样的代码。map层级始终是最高的!

      会不会是你们这个map同层渲染还在灰度呀?

      2019-07-26
      回复
    • 社区技术运营专员-娇华
      社区技术运营专员-娇华
      2019-07-26回复微云

      oh,确认了,目前ios是全量的,Android还没有全量,还在灰度

      2019-07-26
      回复
    查看更多(7)
  • 安逸
    安逸
    2019-10-21

    从 2.8.0 起 map 支持同层渲染,更多请参考原生组件使用限制

    2019-10-21
    赞同
    回复
  • Mr.Ember
    Mr.Ember
    2019-07-25

    现在暂时还不支持同层渲染

    2019-07-25
    赞同
    回复 1
    • 社区技术运营专员-娇华
      社区技术运营专员-娇华
      2019-07-25
      啊,不是的,map在2.7.0已经支持同层了的
      2019-07-25
      回复
登录 后发表内容