收藏
回答

IDE or 基础库bug??

发现几个疑似IDE的bug:


IDE版本:1.02.1807200



  1. IDE选择调试基础库版本为1.9.4 ,结果使用 wx.getSystemInfoSync 获取到的 SDKVersion 却为 1.9.3

  2. 使用 wx.canIUse('button.open-type.openSetting') ,来判断跳转是否可以使用按钮跳转到设置页面时,文档上写的是基础库版本2.0.7已经可以使用,但是是用IDE调试发现,基础库调整到2.1.0时,该方法才返回true,而2.0.7-2.1.0之间,在IDE上直接调用wx.openSetting 会报错....

  3. project.config.json 中设置了 packOptions  ,结果IDE涉及到相关文件还是报错... 这个体验很差啊。

回答关注问题邀请回答
收藏

1 个回答

  • Can🌴
    Can🌴
    2018-07-25

    你的 packOptions 怎么写的, 结果报什么错

    2018-07-25
    赞同
    回复 4
    • waiter
      waiter
      2018-07-25
      "packOptions": {
              "ignore": [
                  {
                      "value": "build",
                      "type": "folder"
                  },
                  {
                      "value": ".gitignore",
                      "type": "file"
                  },
                  {
                      "value": ".project",
                      "type": "file"
                  },
                  {
                      "value": ".md",
                      "type": "suffix"
                  }
              ]
          }



      2018-07-25
      回复
    • Can🌴
      Can🌴
      2018-07-25回复waiter

      难度不是这个意思?

      2018-07-25
      回复
    • waiter
      waiter
      2018-07-25

      我都ignore了,为啥还要如load,然后又load失败导致报Error?按照道理如果已经ignore,这些文件就直接忽略来,不会去load

      2018-07-25
      回复
    • Can🌴
      Can🌴
      2018-07-26回复waiter

      我明白你的意思了。

      这个报错不会影响到你的小程序的调试。我们看看怎么优化这个提示。

      2018-07-26
      回复
登录 后发表内容