收藏
回答

wx.getSetting 调用一直报错?

在插件中判断用户是否授权过,代码如下


报错如下:


已确定小程序开启插件功能,AppID 没有写错。

开发工具版本:Stable v1.02.1907300

2019-09-10 16:09

回答关注问题邀请回答
收藏

4 个回答

  • 社区技术运营专员-灵芝
    社区技术运营专员-灵芝
    2019-09-10

    你好,请检查你的开发者工具网络连接是否有异常

    2019-09-10
    赞同
    回复 11
    • iFangcy
      iFangcy
      2019-09-10
      谢谢回复,开发工具网络连接正常的,开发工具报错 "errMsg: "getSetting:fail 系统错误,错误码:1," ,真机报错 errMsg: "getSetting:fail"
      2019-09-10
      回复
    • 社区技术运营专员-灵芝
      社区技术运营专员-灵芝
      2019-09-10回复iFangcy

      这里麻烦提供一下能复现问题的代码片段,thanks(https://developers.weixin.qq.com/miniprogram/dev/devtools/minicode.html

      2019-09-10
      回复
    • iFangcy
      iFangcy
      2019-09-10回复社区技术运营专员-灵芝
      谢谢 https://developers.weixin.qq.com/s/DHqO7hmL7rbU
      2019-09-10
      回复
    • iFangcy
      iFangcy
      2019-09-11
      你好,目前我们有三个 AppID,经测试只有一个 AppID 在插件中可以正常调用 wx.getSetting,其他两个 AppID 在插件中调用 wx.getSetting 一直报错,请问有解决办法么?
      2019-09-11
      回复
    • iFangcy
      iFangcy
      2019-09-11
      仅在插件中,在小程序中调用正常
      2019-09-11
      回复
    查看更多(6)
  • 谢东寅
    谢东寅
    2019-11-29

    我这边也是,2个小程序  都是在插件中调wx.getSetting 一个走success 一个走fail    getSetting:fail 系统错误,错误码:-12024,the plugin is not bound by the miniprogram

    2019-11-29
    赞同
    回复 3
    • Crystal
      Crystal
      2019-12-01
      亲,看到你的回复我刚试了下,开发者工具2.9.4确实会出现你上面的红色错误。但是在真机上就没有了。我9.18出问题的华为手机和诺基亚手机,现在也都正常了,不会进入wx.getSetting的fail回调了。你用真机看下。
      2019-12-01
      回复
    • 谢东寅
      谢东寅
      2019-12-02回复Crystal
      Ok
      2019-12-02
      回复
    • iFangcy
      iFangcy
      2019-12-04回复谢东寅
      你那边还有问题么,我这边现在又出现了这个问题,但只在某下特定机型下才能复现
      2019-12-04
      回复
  • 雨怡儿
    雨怡儿
    2019-09-30

    目前有解决方案么?

    2019-09-30
    赞同
    回复
  • Crystal
    Crystal
    2019-09-18

    关于这个问题,我这边下午有新的发现——在插件中调用getSetting,测试了几款机型:

    同样是:

    开发工具报错 "errMsg: "getSetting:fail 系统错误,错误码:1," ,真机报错 errMsg: "getSetting:fail"。

    期待官方回复。

    2019-09-18
    赞同
    回复 8
    • iFangcy
      iFangcy
      2019-09-23
      我这边是一个小程序的插件可以正常使用 wx.getSetting,其它几个小程序不能使用 wx.getSetting 一直报错,感觉可能和设备没关系,和 AppID 有关系?朋友你那边解决了么?
      2019-09-23
      回复
    • Crystal
      Crystal
      2019-09-23回复iFangcy
      还没解决,我这边开发者工具 RC v1.02.1909111,基础库2.8.3,插件模式,插件中调用wx.getSetting百分百报错:{errMsg: "getSetting:fail 系统错误,错误码:1,"}
      2019-09-23
      回复
    • iFangcy
      iFangcy
      2019-09-23回复Crystal
      我这也一样,不论哪个版本的开发工具、真机都报这个错,目前还没解决
      2019-09-23
      回复
    • 李新闯
      李新闯
      2019-09-27
      我这边一样的问题,没人管
      2019-09-27
      回复
    • 李新闯
      李新闯
      2019-09-27
      楼主解决了吗?
      2019-09-27
      回复
    查看更多(3)
登录 后发表内容
问题标签