收藏
回答

自定义组件报错

我的小程序在win7的环境编译一切正常。


但是在win10的环境下编译报错,措手不及,不知道怎么解决。。。


求助各位大佬为我解答。


版本我对过了。版本都是一样的。


node版本是6.10.2

wepy 1.7.3


这个问题解决不了过年都是奢望。。。



最后一次编辑于  01-31  (未经腾讯允许,不得转载)
回答关注问题邀请回答
收藏

2 个回答

  • 1906
    1906
    01-31

    在win7 编译是一切正常的。


    换一台电脑什么都是一样的。编译报错。


    [Error] TypeError: Cannot read property 'toString' of undefined

        at new Input (C:\Program Files\nodejs\node_modules\wepy-cli\node_modules\postcss\lib\input.js:51:23)

        at parse (C:\Program Files\nodejs\node_modules\wepy-cli\node_modules\postcss\lib\parse.js:21:17)

        at new LazyResult (C:\Program Files\nodejs\node_modules\wepy-cli\node_modules\postcss\lib\lazy-result.js:70:24)

        at Processor.process (C:\Program Files\nodejs\node_modules\wepy-cli\node_modules\postcss\lib\processor.js:117:12)

        at scopedHandler (C:\Program Files\nodejs\node_modules\wepy-cli\lib\style-compiler\scoped.js:17:63)

        at C:\Program Files\nodejs\node_modules\wepy-cli\lib\compile-style.js:112:49




    安装依赖也是有差别的。

    win10:




    win7


    01-31
    赞同
    回复
  • 卢霄霄
    卢霄霄
    01-31

    你这就很有意思了。。报错是啥都不说。。我能怎么办,我也很绝望啊

    01-31
    赞同
    回复 6
    • 拾忆
      拾忆
      01-31

      你猜呀~

      你猜你猜你猜猜猜~

      01-31
      回复
    • 卢霄霄
      卢霄霄
      01-31回复拾忆

      你猜我猜不猜呢~

      01-31
      回复
    • 1906
      1906
      01-31

      不好意思,太着急了....


      01-31
      回复
    • 卢霄霄
      卢霄霄
      01-31回复1906

      你用了框架啊。。这看不出来,只知道啥哪里没值。。

      01-31
      回复
    • 1906
      1906
      01-31回复卢霄霄

      问题是。我在win7环境下没有报错呀。。。


      主要是这个是接手别人的项目。对这些自定义组件不了解。我也不知道问题出在哪。

      项目是可以正常运行的。应该是环境的原因。


      但又不知道是哪里不对。、。。。

      01-31
      回复
    查看更多(1)