收藏
回答

关于1.9.92更新的强制更新功能,应该如何测试呢?

问题模块 框架类型 API/组件名称 终端类型 操作系统 微信版本 基础库版本
API和组件 小程序 getUpdateManager 微信iOS客户端 Android 6.6.5 1.9.91


https://mp.weixin.qq.com/debug/wxadoc/dev/api/getUpdateManager.html


一、iOS下可以监听到onCheckForUpdate,Android不可以,都做了getUpdateManager的判断


二、测试版本下应如何监听到onUpdateReady、onUpdateFailed回调?


三、测试版本下调用applyUpdate方法没有重启,是否跟没有更新包有关?



最后一次编辑于  2018-03-12  (未经腾讯允许,不得转载)
回答关注问题邀请回答
收藏

6 个回答

  • Special
    Special
    2018-03-12

    下个开发者工具版本可以支持调试,Android 请确认下是否 1.9.90 基础库以上

    2018-03-12
    赞同 1
    回复 1
    • 转身👫 牵着你
      转身👫 牵着你
      2018-06-11

      这个基础库配置不是在开发者工具中配置的嘛?不管安卓还是ios调用时候都是同一个基础库版本把?

      2018-06-11
      回复
  • 小确幸🐾
    小确幸🐾
    2018-04-12

    楼上的是不是基础库版本太低不支持呢

    2018-04-12
    赞同
    回复
  • 张锋
    张锋
    2018-03-20

    提示“wx.getUpdateManager is not a function..." ,怎么整??

    2018-03-20
    赞同
    回复
  • 熊熊波
    熊熊波
    2018-03-15

    这个方法写在哪啊,没看懂啊,

    wx.getUpdateManager 写上去说不说方法导致其他代码也无法加载了


    2018-03-15
    赞同
    回复
  • 韬( ̄▽ ̄)
    韬( ̄▽ ̄)
    2018-03-12

    顶一下

    2018-03-12
    赞同
    回复
  • 韬( ̄▽ ̄)
    韬( ̄▽ ̄)
    2018-03-09

    顶一下

    2018-03-09
    赞同
    回复