收藏
回答

安卓上的web-view内核版本太低,兼容性问题

框架类型 问题类型 API/组件名称 终端类型 操作系统 微信版本 基础库版本
小程序 需求 web-view 客户端 Android 6.6.7 2.1.2

- 需求的场景描述(希望解决的问题)

web-view内核使用的是crosswalk24,chorme内核是53

但是现在部分框架都使用了更高级的API,导致这些比较新的框架都无法在小程序中使用

比如Object.values就无法在chrome53当中兼容

- 希望提供的能力

希望web-view可以提供更高版本的chrome内核

回答关注问题邀请回答
收藏

2 个回答

  • 燮容
    燮容
    2018-07-07

    官方下次更新有计划更新web-view的内核吗?

    2018-07-07
    有用
    回复
  • Rifty
    Rifty
    2018-07-06

    感觉还是别在webview网页里使用太新的js语法

    2018-07-06
    有用
    回复 4
    • 燮容
      燮容
      2018-07-06

      以前web-view用的是chrome57的内核啊

      好像某次微信更新以后就用低版本的内核了

      以前我们的项目是可以正常运行的

      结果现在不能了……

      2018-07-06
      回复
    • 卢霄霄
      卢霄霄
      2018-07-06回复燮容

      上次看他们讨论,说现在好像有53的,比如小米。貌似还有多种内核选择,比较麻烦。。

      2018-07-06
      回复
    • 燮容
      燮容
      2018-07-06回复卢霄霄

      我们开发者能自己选择chrome内核吗?

      2018-07-06
      回复
    • 卢霄霄
      卢霄霄
      2018-07-06回复燮容

      nope。不同的入口不同逻辑会进不同的内核。。上次有人讨论 position:sticky的时候, 官方的 晨 说的

      2018-07-06
      回复
登录 后发表内容