收藏
回答

官方表示微信版本7.0.0才支持 ,单页面自定义导航。

框架类型 问题类型 操作系统 工具版本
小程序 Bug macOS 1.02.1904091

官方表示微信版本7.0.0才支持 ,单页面自定义导航。

bug :开发者工具显示版本号6.6.3,居然也支持,与真机表现不一致。

希望提供修改版本号的入口。


最后一次编辑于  2019-05-15
回答关注问题邀请回答
收藏

2 个回答

  • Valar
    Valar
    2019-05-15

    同样遇到了,只能手机去调试,但是现在找个低版本的真心太难了,6.7.2的貌似已经禁用登录了,希望给个解决方案,或者明确告诉一下是不是所有的7.0.0以下的设备现在都强制升级了?

    2019-05-15
    赞同
    回复
  • 做你的太阳ღ₅₂₀¹³¹⁴
    做你的太阳ღ₅₂₀¹³¹⁴
    2019-05-15

    你的基础库版本号多少?

    2019-05-15
    赞同
    回复 4
    • Raul
      Raul
      2019-05-15

      开发者工具设置的2.7.0

      2019-05-15
      回复
    • 做你的太阳ღ₅₂₀¹³¹⁴
      做你的太阳ღ₅₂₀¹³¹⁴
      2019-05-15回复Raul

      以真机为准吖,或者你更新 开发者工具。或者 你把 基础库调到 6.6.3对应的版本看看

      2019-05-15
      回复
    • Raul
      Raul
      2019-05-15回复做你的太阳ღ₅₂₀¹³¹⁴

      我的开发者工具已经是最新的了,基础库也是2.7.0最高了,

      但是这个开发者工具提供的微信版本号,跟基础库并不能对应上

      存在2个问题,

      1. 我切换基础库并不能改变微信版本号

      2. 微信版本号6.6.3也支持自定义标题(官方表示7.0.0),感觉应该用基础库版本来区分,用微信版本怪怪的。

      2019-05-15
      回复
    • 做你的太阳ღ₅₂₀¹³¹⁴
      做你的太阳ღ₅₂₀¹³¹⁴
      2019-05-15回复Raul

      可以试试开发者工具的开发版以及预发布版本 https://developers.weixin.qq.com/miniprogram/dev/devtools/download.html

      2019-05-15
      回复
登录 后发表内容