收藏
回答

脚本错误 wx.getLaunchOptionsSync 报错?

wx.getLaunchOptionsSync is not a function. (In 'wx.getLaunchOptionsSync()', 'wx.getLaunchOptionsSync' is undefined);at pages/gifts/pages/exchange/exchange formSubmit function;at api login success callback function


回答关注问题邀请回答
收藏

3 个回答

  • 社区技术运营专员-小柿子
    社区技术运营专员-小柿子
    2019-09-03

    线下能复现吗?可能是较低的客户端版本基础库不支持的问题

    2019-09-03
    赞同 1
    回复 3
    • 王帅帅
      王帅帅
      2019-09-03
      可能就是这个问题。 这个错误每人就几个。
      2019-09-03
      回复
    • 社区技术运营专员-小柿子
      社区技术运营专员-小柿子
      2019-09-03回复王帅帅
      试下做个兼容或是限制下基础库版本吧
      2019-09-03
      回复
    • 王帅帅
      王帅帅
      2019-09-03回复社区技术运营专员-小柿子
      开发者工具设置了低版本,就是这个原因,只能做个兼容,低版本就不上传参数了。
      2019-09-03
      回复
  • 王子宴
    王子宴
    2019-12-02

    myError:

    wx.getLaunchOptionsSync is not a function;at App lifeCycleMethod

    onLaunch function TypeError: wx.getLaunchOptionsSync is not a function

    wx.getLaunchOptionsSync不是一个函数;在App lifeCycleMethod onLaunch函数类型错误:wx。同步不是一个函数

    找 设置=>项目设置=>本地设置     改本地版本为最新


    2019-12-02
    赞同 2
    回复 4
    • 🍭
      🍭
      2019-12-02
      哦豁,一不小心发现你了。
      2019-12-02
      回复
    • 王子宴
      王子宴
      2019-12-02回复🍭
      emmmmmm.........
      2019-12-02
      回复
    • 王帅帅
      王帅帅
      2019-12-10
      是的  版本兼容的问题。   是为了尽可能兼容客户,所以选择了低版本。
      2019-12-10
      回复
    • ‮‍君照费
      ‮‍君照费
      02-11
      new B()
      02-11
      回复
  • 忆逝的剧本
    忆逝的剧本
    2019-09-03

    未定义:wx.getLaunchOptionsSync()这个是什么

    2019-09-03
    赞同
    回复
登录 后发表内容
问题标签