收藏
回答

小程序自定义组件低版本兼容问题

问题模块 框架类型 问题类型 操作系统 工具版本
开发者工具 小程序 Bug Windows 1.02.1806120



小程序自定义组件,官方文档写出:所有自定义组件相关特性都需要基础库版本 1.6.3 或更高。

所以自定义组件是可以在1.6.3版本支持的。

但是使用官方文档的代码片段:wechatide://minicode/OMfVAKmZ6KZT

然后将开发者工具的基础库版本切换为1.6.3,开发者工具报错:


只有将基础库版本切换为1.6.6才没有报错。


另外想请问下,这个问题只是在开发者工具上有,还是发布到正式版,也会出现同样的问题?


最后一次编辑于  2018-07-03  (未经腾讯允许,不得转载)
回答关注问题邀请回答
收藏

5 个回答

  • zlm
    zlm
    2018-07-05

    我谈不上大神,不过1.63版本左右的几个版本,一直有问题。据我所知周围人没有解决的。

    2018-07-05
    赞同 3
    回复
  • 隘狭
    隘狭
    2018-07-05

    我是右对齐?

    2018-07-05
    赞同
    回复
  • Freddy马战
    Freddy马战
    2018-07-04


    2018-07-04
    赞同
    回复
  • L
    L
    2018-07-03

    可以来个大神看下吗???

    2018-07-03
    赞同
    回复
  • 张博 Bill
    张博 Bill
    2018-07-03

    我之前还提过一个类似的问题,反正1.6.x的几个基础库有不少问题


    https://developers.weixin.qq.com/blogdetail?action=get_post_info&lang=zh_CN&token=214864838&docid=000c68e38b489838a2a6ffeed56800

    2018-07-03
    赞同
    回复 2
    • L
      L
      2018-07-03

      主要想定位问题是,只在开发者工具上才有这种bug还是正式版微信上也有这种bug,官方的人也不解释下,让我们开发人员很难受:(

      2018-07-03
      回复
    • 张博 Bill
      张博 Bill
      2018-07-03回复L

      应该是开发工具的问题,至少我在客户端没遇到过这种问题。


      此外1.6.x基础库用户也比较少了,可以不用纠结了



      2018-07-03
      回复