收藏
回答

矢量图标显示不出来?

.wxss

@font-face {

    font-family: 'iconfont';  /* project id 2448503 */

    src: url('//at.alicdn.com/t/font_2448503_v1tw2vdebvs.eot');

    src: url('//at.alicdn.com/t/font_2448503_v1tw2vdebvs.eot?#iefix') format('embedded-opentype'),

    url('//at.alicdn.com/t/font_2448503_v1tw2vdebvs.woff2') format('woff2'),

    url('//at.alicdn.com/t/font_2448503_v1tw2vdebvs.woff') format('woff'),

    url('//at.alicdn.com/t/font_2448503_v1tw2vdebvs.ttf') format('truetype'),

    url('//at.alicdn.com/t/font_2448503_v1tw2vdebvs.svg#iconfont') format('svg');

  }

  .iconfont {

    font-family: "iconfont" !important;

    font-size: 30rpx;

    font-style: normal;

    -webkit-font-smoothing: antialiased;

    -moz-osx-font-smoothing: grayscale;

  }

  .icon-dizhi:before {

    content: "\e61d";

  }

  

  .icon-jiahao:before {

    content: "\e721";

  }

  

  .icon-xiaoxi:before {

    content: "\e66c";

  }

  

  .icon-zhuye:before {

    content: "\e605";

  }

  

  .icon-wode:before {

    content: "\e699";

  }

wxml:

 <view><icon id="iconfont">&#xe721;</icon></view>

                <view><icon class="iconfont">&#xe61d;</icon></view>

在运行的时候只显示&#e61d;为什么不显示对应的图标

回答关注问题邀请回答
收藏

2 个回答

  • 上巴
    上巴
    2021-05-03

    我最近也发现了,矢量图标下载下来的css文件放到wxss中就不能用了,不知道题主解决了这个问题没有

    2021-05-03
    有用
    回复
  • Cjiang
    Cjiang
    2021-03-29

    你好,请具体描述问题出现的流程,并提供能复现问题的简单代码片段(https://developers.weixin.qq.com/miniprogram/dev/devtools/minicode.html)。

    2021-03-29
    有用
    回复
登录 后发表内容
问题标签