收藏
回答

import statement may only appear at the top level?

在开发者工具上一切正常,但是生成真机预览或调试时会报这个错。

回答关注问题邀请回答
收藏

3 个回答

  • 社区技术运营专员-阳光
    社区技术运营专员-阳光
    2020-10-15

    你好,哪个版本的工具呢?提供能复现问题的简单代码片段(https://developers.weixin.qq.com/miniprogram/dev/devtools/minicode.html)。

    2020-10-15
    有用
    回复 5
    • SsSsSs
      SsSsSs
      2021-01-01
      我的也是这个问题!https://developers.weixin.qq.com/s/6bldp2mt7Vnu
      2021-01-01
      回复
    • SsSsSs
      SsSsSs
      2021-01-02
      ES6转ES5 已解决
      2021-01-02
      1
      回复
    • 文果
      文果
      2021-08-18回复SsSsSs
      你好,请问你是怎么转的
      2021-08-18
      回复
    • 、扬
      、扬
      2021-10-29回复SsSsSs
      正解,感谢
      2021-10-29
      回复
    • 、扬
      、扬
      2021-10-29回复文果
      开发者工具,详情-本地设置里
      2021-10-29
      回复
  • SsSsSs
    SsSsSs
    2021-01-01

    您好,我也遇到这个问题,您有没有解决?

    2021-01-01
    有用
    回复
  • Lee
    Lee
    2020-12-27

    你好,我也碰到这个问题:

    点击预览(preview)报错如下:

    2020-12-27
    有用
    回复 1
    • Lee
      Lee
      2020-12-27
      macos
      wechat devtools 1.03.2012121
      2020-12-27
      回复
登录 后发表内容
问题标签