收藏
回答

由于用户的小程序版本不是最新导致无法跳转

  1. 小程序里新增了页面,但是该页面的入口时后端控制的,所以会出现以下问题

  2. 活动上线时,入口露出,并且跳转路径配置好,但是,有可能看到入口的时候,小程序版本不是最新,所以会导致跳转找不到路径,

    配置了pageNotFound也没有跳转,请问如何避免此类情况的发生,想到的一种方案是在小程序里放置一个版本号,跳转的时候判断一下 版本号,如果是最新的就直接跳转,如果不是提示用户去更新,那又有一个问题了,如何弹窗让用户主动更新,而不是删除使用记录, 还有一些版本的微信不会提示更新,请问官方有没有解决方案

最后一次编辑于  03-28
回答关注问题邀请回答
收藏

1 个回答

  • 社区技术运营专员-娇华
    社区技术运营专员-娇华
    03-28

    关于更新的问题请阅读文档运行机制:https://developers.weixin.qq.com/miniprogram/dev/framework/operating-mechanism.html



    应用最新版本,可以使用 wx.getUpdateManager API 进行处理。

    03-28
    赞同
    回复 2
    • 云拓互动传媒有限公司
      云拓互动传媒有限公司
      03-28

      这个地方我看了,是在任何地方都可以使用 这个方法去下载更新么,还是说,只有版本有更新的时候,才会获得manager对象

      03-28
      回复
    • 社区技术运营专员-娇华
      社区技术运营专员-娇华
      03-28回复云拓互动传媒有限公司

      获取全局唯一的版本更新管理器,用于管理小程序更新。只有版本更新的时候才可以的

      03-28
      回复