收藏
回答

由于用户的小程序版本不是最新导致无法跳转

  1. 小程序里新增了页面,但是该页面的入口时后端控制的,所以会出现以下问题

  2. 活动上线时,入口露出,并且跳转路径配置好,但是,有可能看到入口的时候,小程序版本不是最新,所以会导致跳转找不到路径,

    配置了pageNotFound也没有跳转,请问如何避免此类情况的发生,想到的一种方案是在小程序里放置一个版本号,跳转的时候判断一下 版本号,如果是最新的就直接跳转,如果不是提示用户去更新,那又有一个问题了,如何弹窗让用户主动更新,而不是删除使用记录, 还有一些版本的微信不会提示更新,请问官方有没有解决方案

回答关注问题邀请回答
收藏

1 个回答

登录 后发表内容