收藏
回答

小程序插件能否支持npm包

问题模块 问题类型 插件 AppID 插件版本号 AppID 操作系统 微信版本 基础库版本
插件 Bug wxc5dd0ce5835e91f8 1 wxc5dd0ce5835e91f8 iOS 6.6.7 2.3.0

- 当前 Bug 的表现(可附上截图)


目前开发插件,遇到插件不支持npm包,请问@官方,目前插件是否支持npm包,有何办法?


- 预期表现


- 复现路径


- 提供一个最简复现 Demo


最后一次编辑于  01-10  (未经腾讯允许,不得转载)
回答关注问题邀请回答
收藏

1 个回答

  • 僵尸浩
    僵尸浩
    01-10

    https://developers.weixin.qq.com/miniprogram/dev/devtools/npm.html

    看看这份指引能不能满足你的要求?

    01-10
    赞同
    回复 16
    • colemama
      colemama
      01-10

      开发小程序npm组件我已经了解,主要是我们在开发小程序插件的时候需要引入npm包,这个应该怎么引入?

      01-10
      回复
    • 僵尸浩
      僵尸浩
      01-10回复colemama

      原理是一样的,在plugin目录下安装node_modules,再构建npm包即可。miniprogram目录不支持构建npm

      01-10
      回复
    • colemama
      colemama
      01-10回复僵尸浩

      不好意思,还是得请教你,构建什么的都没有问题,主要是引入组件的时候报错,您请看,一直报找不到组件

      01-10
      回复
    • 僵尸浩
      僵尸浩
      01-10回复colemama

      这个直接打一个代码片段来看看?

      01-10
      回复
    • colemama
      colemama
      01-10回复僵尸浩

      https://developers.weixin.qq.com/s/VNRTajmu7u5j

      您看看,多谢多细!

      01-10
      回复
    查看更多(11)