收藏
回答

ide更新后报错modification of global variable "define" ?

当前最新的开发者工具,版本:1.05.2102010

之前运行无报错,现在编译后,控制台报错,报错如下:

modification of global variable "define" is not allowed when using plugins at app.json.

modification of global variable "require" is not allowed when using plugins at app.json.

app.json的配置,没更新工具之前不会报错

回答关注问题邀请回答
收藏

1 个回答

  •  Turing
    Turing
    02-03

    看起来是weui修改了全局变量,在使用插件的条件下,基础库不允许改写一些全局变量

    02-03
    有用
    回复 7
    • Aquarius
      Aquarius
      02-03
      那是等官方修复是吗
      02-03
      1
      回复
    •  Turing
      Turing
      02-03回复Aquarius
      这边会排查这个问题,尽快修复
      02-03
      回复
    • Aquarius
      Aquarius
      02-03
      好的,谢谢
      02-03
      回复
    • 是谁走漏了风声
      是谁走漏了风声
      02-22
      希望官方能够尽快解决,setPrototypeOf 方法在企业微信环境下无返回值,导致企业微信下小程序无法使用
      02-22
      回复
    • 是谁走漏了风声
      是谁走漏了风声
      02-22回复是谁走漏了风声
      ios 正常,安卓异常
      02-22
      回复
    查看更多(2)
登录 后发表内容
问题标签