收藏
回答

商户API证书升级,新老系统兼容问题

场景:部门1使用的微信支付为API V2版本,商户号证书使用的是微信支付颁发的API证书,该套V2版本服务端已经服务多个客户端。现部门2使用API V3版本开发了新的支付服务端,不支持微信支付颁发的API证书

问题:该商户号升级为权威CA颁发的API证书后,

1、部门1的原V2版本服务端项目代码是否需要改动?

2、历史客户端是否能直接接通部门2新开发的V3版本服务端?

3、部门2新开发的支付服务端是否需要针对两种类型(微信颁发、CA颁发)的证书做兼容处理?

回答关注问题邀请回答
收藏

1 个回答

  • 北望沣渭
    北望沣渭
    03-31
    1. 部门1 的项目代码,可以不用改动,但需要监测是否支持CA证书;
    2. 你们的客户端,访问的服务端用的是什么协议?只要你们的服务端按照提供给客户端的API接口做适配,就应该可以平滑切换至v3版服务端;
    3. 微信支付官方,已经不再颁发私有证书了,全部换成CA证书了,部门2理论上无需做兼容。
    03-31
    有用
    回复
登录 后发表内容
问题标签