收藏
回答

CLI调用报错

问题模块 框架类型 问题类型 操作系统 工具版本
开发者工具 小程序 Bug macOS 1.02.1810250

- 当前 Bug 的表现(可附上截图)

同样的一个project.config.json,使用cli调用失败,手动用开发者工具打开就可以。


- 预期表现

使用cli调用可以正确打开小程序。


- 复现路径

{
    "description": "项目配置文件",
    "packOptions": {
        "ignore": []
    },
    "setting": {
        "urlCheck": true,
        "es6": false,
        "postcss": true,
        "minified": false,
        "newFeature": true
    },
    "compileType": "miniprogram",
    "libVersion": "2.3.2",
    "appid": "wxaf7296aa719f52e2",
    "projectname": "wxa-templates",
    "miniprogramRoot": "base/dist/",
    "debugOptions": {
        "hidedInDevtools": []
    },
    "isGameTourist": false,
    "condition": {
        "search": {
            "current": -1,
            "list": []
        },
        "conversation": {
            "current": -1,
            "list": []
        },
        "game": {
            "currentL": -1,
            "list": []
        },
        "miniprogram": {
            "current": -1,
            "list": []
        }
    }
}


- 提供一个最简复现 Demo


最后一次编辑于  2018-11-01
回答关注问题邀请回答
收藏

2 个回答

  • 社区技术运营专员-灵芝
    社区技术运营专员-灵芝
    2018-11-01

    开发工具版本是v1.02.1810250?

    2018-11-01
    赞同
    回复 4
    • Genuifx
      Genuifx
      2018-11-02

      是的,macOS


      2018-11-02
      回复
    • 社区技术运营专员-灵芝
      社区技术运营专员-灵芝
      2018-11-02回复Genuifx

      参考楼上的回复是否能解决问题?

      2018-11-02
      回复
    • Genuifx
      Genuifx
      01-23

      现在遇到另外一个问题,三方开发的小程序命令行调用会报这个错误, 而直接在工具里面上传是可以上传成功的

      @nickname


      { StatusCodeError: 400 - "{\"code\":40000,\"error\":\"错误 Error: ext.json\\nExpecting 'STRING','NUMBER','NULL','TRUE','FALSE','{','[', got INVALID\\n  1 | undefined\"}"

      01-23
      回复
    • 社区技术运营专员-灵芝
      社区技术运营专员-灵芝
      01-23回复Genuifx

      麻烦重新发帖提问哈,详细描述一下问题

      01-23
      回复
  • 似水流年
    似水流年
    2018-11-01

    同样遇到了如此bug。win系统下,project.config.json明明存在,路径也没错,就是报不存在,服了。工具版本v1.02.1809260。

    手动上传不存在问题。命令行用不成啊。

    无论是预览,还是上传,都是同样的bug。

    看看是不是我路径有问题:

    >cli -u 1.1.3@\F:\work\fe-test\dist\fe-test --upload-desc 'test cli'


    -------------------


    追加:


    终于搞定了,应当是路径的问题。注意,命令输入过程不要有任何的光标返回修改操作。一次到位就没问题,修改到位也会失败。

    2018-11-01
    赞同
    回复