收藏
回答

div现在不支持了吗,不是块级元素了。。

框架类型 问题类型 终端类型 微信版本 基础库版本
小程序 Bug 工具 6.7.4 2.4.1

- 当前 Bug 的表现(可附上截图)

div现在不支持了吗,不是块级元素了。。


- 预期表现


- 复现路径


- 提供一个最简复现 Demo


回答关注问题邀请回答
收藏

8 个回答

  • 清蒸鱼
    清蒸鱼
    02-28

    ...那web网页怎么直接迁移到小程序上?重新开发一遍吗

    02-28
    有用
    回复
  • 白纸
    白纸
    2018-12-24

    抱歉,过来楼主这问个问题,我的小程序跳到外链以后用我wx.miniProgram.navigateTo为何跳不回去指定地址,而且还有success和complete指定回调。求解释

    2018-12-24
    有用
    回复 3
    • 加凉多茶宝
      加凉多茶宝
      2018-12-24

      不要用wx.miniProgram.navigateTo,请直接用wx.navigateTo ,谢谢,miniProgram接口在2.0版本之后就淘汰了

      2018-12-24
      回复
    • 白纸
      白纸
      2018-12-24回复加凉多茶宝

      是吗?我在webview那篇介绍里面说就是这个借接口,官方改了都不注释?

      2018-12-24
      回复
    • 白纸
      白纸
      2018-12-24回复加凉多茶宝

      试了不行。

      2018-12-24
      回复
  • aholy
    aholy
    2018-12-24

    100=60+40*0.8+8

    2018-12-24
    有用
    回复
  • Sunflower⁶₆⁶₆⁶₆
    Sunflower⁶₆⁶₆⁶₆
    2018-12-24

    大哥儿你好执着啊    你用官方推荐的吧

    2018-12-24
    有用
    回复
  • 吃草的小绵羊
    吃草的小绵羊
    2018-12-24

    那就把div替换成view,官方文档一开始就不建议用div,这种问题他们不会理你的

    2018-12-24
    有用
    回复
  • 黎😄
    黎😄
    2018-12-21

    我记得有段时间一写html标签就会报错。今年年中好像突然又可以写了,写了不报错,样式也有效,但是都不是块级元素来的。不建议使用,万一某天突然又不能用了,那不是悲剧了?毕竟文档没说可以用。

    2018-12-21
    有用
    回复 1
    • 王天庆🐣
      王天庆🐣
      2018-12-21

      主要是之前写的好多有写div,今天上线了才发现有问题了。。  官方也没有一个准确的答复。。

      2018-12-21
      回复
  • ==
    ==
    2018-12-21

    不是div是view   !!!   是时候把大佬的个签搬出来了!!

    2018-12-21
    有用
    回复 3
    • 王天庆🐣
      王天庆🐣
      2018-12-21

      这个我知道 因为小程序有一部分 是继续用的div 写的 之前没有问题,今天发了一个版本 发现 div 不是块级元素了

      2018-12-21
      回复
    • 王天庆🐣
      王天庆🐣
      2018-12-21回复王天庆🐣

      愁死了

      2018-12-21
      回复
    • ==
      ==
      2018-12-21回复王天庆🐣

      哈哈哈!!,建议用view,,虽然之前的基础库还能用!!

      2018-12-21
      回复
  • Stephen
    Stephen
    2018-12-21

    小程序不是html,没有div

    2018-12-21
    有用
    回复 2
登录 后发表内容