收藏
回答

微信小程序typescript默认模板无法构建npm,想问下微信小程序现在是否较好的支持了TS?

本想使用TS开发小程序,通过测试账号创建了一个TS的默认模板,有问题。所以有两个问题想咨询一下:

  1. 默认模板为啥会跑不起来?是否有解决方案? PS: 下方会列出具体遇到的错误
  2. 现在小程序对TS是否有良好的支持?还是后期有了更好的支持在使用TS开发小程序?

首先是创建好TS模板后,使用 构建npm 报 “没有找到可以构建的NPM包”,然后在社区中找相关的帖子,并根据帖子进行修改(https://developers.weixin.qq.com/community/develop/article/doc/00040e8fd645a033d0f8502bf5b813 根据此贴进行的修改),然后点击 构建NPM,报错 “不能允许使用require变量” (具体报错信息看下图)

然后是 utils.ts 文件中报各种错。(个人猜测是 TS 没有正确引入的原因。)

然后尝试将 typescript 和 miniprogram-api-typings 变更为 devDependencies 依赖,构建NPM 后又报 “没有找到可以构建的NPM包

PS:开发者工具的版本是 Stable v1.02.1910120

最后一次编辑于  2019-12-24
回答关注问题邀请回答
收藏

3 个回答

  • Jation
    Jation
    2020-03-09

    你好,很抱歉为你带来不便,这个问题已经在nightly得到修复,下载请移步:

    https://developers.weixin.qq.com/miniprogram/dev/devtools/nightly.html


    2020-03-09
    有用
    回复 1
  • RedHood
    RedHood
    2019-12-24

    把 dependencies 改成 devDependencies 后 npm install 一下,typescript 定义文件是不需要进行 npm 构建的。

    2019-12-24
    有用
    回复 3
    • 大橘为重
      大橘为重
      2019-12-27
      试过改成 devDependencies。但是文件中各种红线报错,就像第三张图那样
      2019-12-27
      回复
    • RedHood
      RedHood
      2019-12-27回复大橘为重
      你执行下 npm install
      2019-12-27
      回复
    • 浮生
      浮生
      2020-02-12
      按照 把 dependencies 改成 devDependencies 后 npm install 一下  还是看找不NPM包
      2020-02-12
      回复
  • 释怀的天空
    释怀的天空
    2020-01-25

    我的也是,本来想用ts重构项目的,但是也出现这种情况,有没有好的解决方案?

    2020-01-25
    有用
    回复
登录 后发表内容
问题标签