收藏
回答

更新开发工具后app.json报错

问题模块 框架类型 问题类型 操作系统 工具版本
开发者工具 小程序 Bug Windows v1.02.1901170

VM94:5 appJSON["window"]["backgroundTextStyle"] 字段需为 dark 或 light



代码正常啊!之前好好地,昨天更新版本后,今天·启动失败


"window": {

"backgroundTextStyle": "#fff",

"navigationBarBackgroundColor": "#fff",

"navigationBarTitleText": "wheact",

"navigationBarTextStyle": "black"

},






现在是删除我原有的,改为微信默认的,照样提示错误,如图

最后一次编辑于  01-21  (未经腾讯允许,不得转载)
回答关注问题邀请回答
收藏

11 个回答

  • 社区技术运营专员-灵芝
    社区技术运营专员-灵芝
    01-21

    你好,这个文档有说明的哈:https://developers.weixin.qq.com/miniprogram/dev/framework/config.html#%E5%85%A8%E5%B1%80%E9%85%8D%E7%BD%AE

    帖子中改的不是提示错误的字段哈,请确认



    01-21
    赞同
    回复 13
    查看更多(8)
  • 永远的24号
    永远的24号
    01-22

    开发工具怎么搞得


    01-22
    赞同 1
    回复
  • 赵宽@步子山
    赵宽@步子山
    03-14

    现在改了,苹果手机显示各种导航栏色彩异常,导航栏黑色,

    03-14
    赞同
    回复
  • 何大小成
    何大小成
    01-28

    我的也出问题

    01-28
    赞同
    回复
  • 邓疯疯 
    邓疯疯 
    01-22

    VM9970:5 pageJSON["navigationBarTextStyle"] 字段需为 black 或 white

    "window": {

    "navigationBarBackgroundColor": "#f8f8f8",

    "navigationBarTextStyle": "white",

    "navigationBarTitleText": "xxxx",

    "backgroundColor": "#eeeeee",

    "backgroundTextStyle": "dark",

    "enablePullDownRefresh": false

    }

    一样的报错,不明白了


    01-22
    赞同
    回复
  • 小星
    小星
    01-22

    更新后是有好多不能用了,我也遇见了于是都删除或者更改了

    01-22
    赞同
    回复
  • Terry
    Terry
    01-22

    你的错误是backgroudTextStyle

    01-22
    赞同
    回复 1
    • I'am  大豆博文
      I'am 大豆博文
      01-22

      ok,按官方来就没事了,之前可能是bug

      01-22
      回复
  • 哆啦C梦
    哆啦C梦
    01-21

    在更新最新的之前,编译和运行没问题的,现在也报这个问题

    01-21
    赞同
    回复
  • Can🌴
    Can🌴
    01-21

    哥,仔细看一下报错。



    01-21
    赞同
    回复 2
    • I'am  大豆博文
      I'am 大豆博文
      01-21

      受教,已经解决,之前太不细心了

      01-21
      回复
    • super
      super
      03-09回复I'am 大豆博文

      解决方法呢?

      03-09
      回复
  • I'am  大豆博文
    I'am 大豆博文
    01-21

    有官方人员方便作答下吗?

    01-21
    赞同
    回复

正在加载...