收藏
回答

wx.getUserProfile is not a function?

console.log('getUserProfile', wx.getUserProfile),   //  getUserProfile undefined
console.log('canIUse', wx.canIUse('wx.getUserProfile'))  //canIUse false

回答关注问题邀请回答
收藏

11 个回答

  • 耿霄
    耿霄
    2021-03-05

    https://developers.weixin.qq.com/community/develop/article/doc/00040885c386f81e96cbf93cf51013希望对你有帮助哈

    2021-03-05
    有用 2
    回复 1
    • Lu
      Lu
      2021-03-05
      好的,谢谢大佬
      2021-03-05
      回复
  • Lu
    Lu
    2021-03-05

    找到了,是基础库的原因,不支持2.14.0

    2021-03-05
    有用 4
    回复 3
    • 大黑皮
      大黑皮
      2021-03-05
      坑的要死,,文档上写的是2.10.5就支持 我试了2.14.0 不支持 然后 2.14.1 居然支持了…… 一气之下直接上2.15.0了。。
      2021-03-05
      1
      回复
    • Lu
      Lu
      发表于移动端
      2021-03-05回复大黑皮
      我试的时候也在想2.14.0是高于2.10的😂但是用不起,我也改成2.15.0
      2021-03-05
      1
      回复
    • ALKAO.UA
      ALKAO.UA
      04-10
      我就纳闷了,官方文档就不能改改
      04-10
      1
      回复
  • Smooth
    Smooth
    2021-11-12

    基础库这个坑emm

    2021-11-12
    有用 1
    回复
  • 非衣
    非衣
    2021-09-24

    真是,调试半天,必须登录说两句,气人,气人,气人

    2021-09-24
    有用
    回复
  • 口天一止....
    口天一止....
    2021-09-07

    气的第一次登录评论,还是二楼正解啊

    2021-09-07
    有用
    回复
  • A杭州武当太极功夫馆
    A杭州武当太极功夫馆
    2021-07-03

    为什么会有小程序开发,这就是个坑。

    2021-07-03
    有用
    回复
  • McCall
    McCall
    2021-04-27

    淦!!!


    2021-04-27
    有用
    回复
  • Promise
    Promise
    2021-04-27

    2.14.3和2.14.4都不支持,坑我半天

    2021-04-27
    有用
    回复
  • 飞
    2021-04-21

    这文档的最低版本怎么跟玩似得~

    2021-04-21
    有用
    回复
  • 幻风
    幻风
    2021-04-08

    在手机上,这个接口没问题。我想问的是在PC端打开小程序,不支持这个接口。用PC真机调试也不行,请看如下截图。PC真机调试时,显示的基础库版本是2.11.0,不是说的2.10.4就支持吗?那么PC端小程序什么时候能支持wx.getUserProfile??在线等,PC不支持很不方便

    2021-04-08
    有用
    回复 2
    • 红红火火恍恍惚惚
      红红火火恍恍惚惚
      2021-04-27
      好像是的
      2021-04-27
      1
      回复
    • Huang98
      Huang98
      2021-06-09
      相同问题求解
      2021-06-09
      回复

正在加载...

登录 后发表内容
问题标签