收藏
回答

小程序使用wx.switchTab跳转后页面白屏

具体是小程序完成注册后跳转到用户主页后页面直接白屏,向右滑动后小程序直接关门,没有显示返回控件但盲点左上角可以返回,以上问题测试仅在安卓系统有发现,真机调试控制台没有异常,ios正常。

最后一次编辑于  01-26
回答关注问题邀请回答
收藏

6 个回答

  • 忠伟
    忠伟
    08-12

    我也碰到这个问题了,在真机IOS上点击按钮跳转,调用wx.switchTab会出现页面白屏

    08-12
    有用
    回复
  • 螺丝钉
    螺丝钉
    03-23

    组件所在页面的生命周期


    pageLifetimes: {
        show: function() {
          // 页面被展示
        }
    }
    


    这是个不同的事件


    03-23
    有用
    回复 1
    • 请酒
      请酒
      05-12
      不懂你的意思
      05-12
      回复
  • 灿灿
    灿灿
    01-19

    请问问题解决了么?

    01-19
    有用
    回复 2
    • 王多rou
      王多rou
      01-26
      还是没有解决..我加了个空白页面来判断跳转..也不算是完美解决....
      01-26
      回复
    • 王明
      王明
      星期三 18:01
      解决了么
      星期三 18:01
      回复
  • 小白白白白
    小白白白白
    01-15

    楼主解决了吗?遇到了同样的问题

    01-15
    有用
    回复 1
    • 王多rou
      王多rou
      01-26
      还是没有解决..我加了个空白页面来判断跳转..也不算是完美解决....
      01-26
      回复
  • 面条君
    面条君
    01-04

    看了一眼代码似乎没啥大问题,真机调试一下看看dom有没有加载,打开手机调试看看有没有出现vconsole,另外你代码里好像没打开增强编译,打开试试看

    01-04
    有用
    回复 5
    • 王多rou
      王多rou
      01-04
      dom有加载 就是显示的是个白的 我看wxml都改变了 只有安卓有这个问题..
      01-04
      回复
    • 王多rou
      王多rou
      01-04
      增强我之前也开了 应该不是这个..
      01-04
      回复
    • 面条君
      面条君
      01-04回复王多rou
      控制台没报错dom内容样式正常加载的话,就只能检查下样式了,安卓和ios样式加载有一定差异
      01-04
      回复
    • 王多rou
      王多rou
      01-04回复面条君
      好的好的 我百度康康 谢谢!
      01-04
      回复
    • 小舒
      小舒
      04-29回复王多rou
      我也遇到了 请问有什么解决办法吗
      04-29
      回复
  • null
    null
    01-04

    打开调试,查看报错信息。

    01-04
    有用
    回复 17
    查看更多(12)
登录 后发表内容
问题标签