收藏
回答

插件可以设置最低基础库版本吗?

小程序可以设置最低基础库版本,插件是否也有这样的设置,比如说插件中使用的方法可能基于某个版本库的特性,如果小程序的最低基础库版本低于插件可用的基础库版本,则会造成插件报错,进而使小程序也报错,是否有这样的功能,当使用插件的小程序的基础库版本低于插件的可用版本库是能给出相应的提示

回答关注问题邀请回答
收藏

1 个回答

  • 社区技术运营专员-娇华
    社区技术运营专员-娇华
    2019-12-11

    插件的开发和使用自小程序基础库版本 1.9.6 开始支持。(如果插件包含页面,则需要基础库版本 2.1.0 )可设置小程序最低基础库版本https://developers.weixin.qq.com/miniprogram/dev/framework/compatibility.html

    2019-12-11
    赞同
    回复 3
    • 逆冰
      逆冰
      2019-12-11
      嗯,这个是,只是插件是给别人使用的,没有一个有效的措施去限制使用者的基础版本库,就算是在插件的说明文档标明,使用者也不一定会去做,同时也是增加了工作成本.我这边的问题是Uint8Array的问题,Uint8Array是在基础库2.9.2及之后才支持的,在插件开发中用到了Uint8Array,结果有人反馈插件报错,导致小程序无法使用了,经过测试才有了这个问题
      2019-12-11
      回复
    • 社区技术运营专员-娇华
      社区技术运营专员-娇华
      2019-12-12回复逆冰
      目前暂不支持哈,后续会考虑支持
      2019-12-12
      回复
    • 逆冰
      逆冰
      2019-12-12回复社区技术运营专员-娇华
      好的
      2019-12-12
      回复
登录 后发表内容
问题标签