收藏
回答

小程序无法预览,开启调试模式后正常

问题模块
API和组件

RT,求解是为什么?

使用iPhone6s 10.0.0预览,页面一片空白,不知道是哪里出错,然后打开调试模式查看log。

却发现打开调试模式后一切正常。希望有相关人员能够看下。


PS: 开发者工具上完全没有问题!

最后一次编辑于  2017-01-03
回答关注问题邀请回答
收藏

22 个回答

  • 乐哈哈
    乐哈哈
    2017-06-24

    怪事 ,我发现调试模式和真机模式就是有不同

    wx.request 的参数,如果写在data里,用json模式提交,调试模式正常,真机不行

    之后把参数都写在url上,问题就解决了

    2017-06-24
    赞同 1
    回复
  • 为亭
    为亭
    2017-06-01

    安全域名配置一下

    2017-06-01
    赞同 1
    回复
  • 踟蹰
    踟蹰
    2018-07-23

    我也遇到同样问题 页面无法跳转 手机有预览打开开发模式才行

    2018-07-23
    赞同
    回复
  • 石勇
    石勇
    2018-06-14

    我的小程序也是,体验版只有打开调试才正常,不打开调试,没有数据,解决办法就是在你的小程序公众平台上,找到设置中的开发设置,增加一个你用到的合法域名就行了

    2018-06-14
    赞同
    回复
  • 王祥
    王祥
    2018-04-26

    接上楼,群号609957465,方便电脑登录的用户加群

    2018-04-26
    赞同
    回复
  • 王祥
    王祥
    2018-04-26

    已解决,通过二分法找了所有的版本,发现问题是 console.assert 这个指令在移动端不支持导致的。

    有兴趣的可以加群一起交流学习啊。


    2018-04-26
    赞同
    回复
  • 🇨🇳家里有个小怪兽
    🇨🇳家里有个小怪兽
    2018-04-23

    我用的接口都是测试版 带端口的, 所以在手机端也是要打开开发模式的  这个不是bug,我相信你在用这个开发工具的时候也是“不校验合法域名、web-view(业务域名)、TLS 版本以及 HTTPS 证书”勾上了这一段的,对吧   所以不是bug,是确实是需要打开开发模式

    2018-04-23
    赞同
    回复 1
    • Viola
      Viola
      2018-06-26

      那这个是在开发者工具上勾上了那个 以后,就没有问题了吗?那如果是上线版本呢?也没有问题吗?  求回答一下啊

      2018-06-26
      回复
  • Allen
    Allen
    2018-04-19

    最后解决了吗?我现在也遇到了

    2018-04-19
    赞同
    回复
  • 王祥
    王祥
    2018-04-12

    我也遇到了这个问题啊。至今没解决啊

    2018-04-12
    赞同
    回复
  • 逐风慕雨
    逐风慕雨
    2017-11-28

    请问这个问题最后是怎么解决的?

    2017-11-28
    赞同
    回复

正在加载...

登录 后发表内容