收藏
回答

component中require公共js手机预览报错开发者工具中不报错

问题模块
API和组件



path:

    component/app/index.js

code:

var util = require('../../utils/util.js')

其他发现:

若在小程序app.json中配置

pages:["component/app/index"] 预览时可正常require



最后一次编辑于  2017-11-08  (未经腾讯允许,不得转载)
回答关注问题邀请回答
收藏

4 个回答

  • 沈永强
    沈永强
    2017-11-15

    现在不报错了  赞一个

    2017-11-15
    赞同
    回复
  • 小程序技术专员-LastLeaf
    小程序技术专员-LastLeaf
    2017-11-15

    现在还会报错吗?

    2017-11-15
    赞同
    回复
  • 沈永强
    沈永强
    2017-11-15

    不是把pages/index/index作为自定义组件


    关键点是component/app/index.js作为自定义组件  require公共js  手机预览报错(开发者工具不报错)



    2017-11-15
    赞同
    回复
  • 小程序技术专员-LastLeaf
    小程序技术专员-LastLeaf
    2017-11-08

    你好,看你的第一个错误,是不是尝试将“pages/index/index”作为自定义组件使用?

    2017-11-08
    赞同
    回复