收藏
回答

wxml-to-canvas最新版本(1.1.1)控制台会给出“canvas 2d 接口...“警告

框架类型 问题类型 API/组件名称 终端类型 微信版本 基础库版本
小程序 Bug wxml-to-canvas 工具 7.0.9 2.10.4

wxml-to-canvas最新版本(1.1.1)在控制台会警告“canvas 2d 接口支持同层渲染且性能更佳,建议切换使用”

官方给出的代码片段中wxml-to-canvas版本是1.0.1就不会出现警告

回答关注问题邀请回答
收藏

1 个回答

  • 社区技术运营专员-娇华
    社区技术运营专员-娇华
    09-11

    因为你用了旧的canvas

    09-11
    有用
    回复 1
    • ______
      ______
      星期二 09:58
      官方的扩展组件,默认不是用的最新吗。后面我看过扩展组件源码,是根据基础库版本来判断的,基础库版本大于2.9.2使用的canvas 2d。
      我的基础库2.10.4使用组件是新的2d接口,调试器wxml面板可以看到。那我猜测是开发者工具没有正确判断
      星期二 09:58
      回复
登录 后发表内容
问题标签