收藏
回答

微信7.0.3cover-view无法覆盖live-player问题

问题模块 框架类型 问题类型 API/组件名称 终端类型 微信版本 基础库版本
API和组件 小程序 Bug live-player 客户端 7.0.3 2.7.4

- 当前 Bug 的表现(可附上截图)

在7.0.3版本下cover-view设置了z-index无效,cover-view无法覆盖在live-player上面

但是在7.0.4设置z-index又有效


- 预期表现

cover-view可以覆盖在live-player之上


邀请回答
复制链接收藏投诉关注问题回答

3 个回答

  • nickname
    nickname
    07-10

    更新一下微信版本是否正常?

    麻烦提供出现问题的具体机型、微信版本号、系统版本号,以及能复现问题的代码片段(https://developers.weixin.qq.com/miniprogram/dev/devtools/minicode.html

    07-10
    赞同
    回复 3
    • Stay
      Stay
      07-10

      更新微信版本是可以覆盖的,但是在7.0.3如何解决呢?

      07-10
      回复
    • Stay
      Stay
      07-10

      在7.0.3版本下 所有的机型都是一样覆盖不了的

      07-10
      回复
    • nickname
      nickname
      07-10回复Stay

      不清楚你的代码具体是怎么写的,但是小程序需要在 v2.7.0 及以上版本才支持在样式中声明 z-index 来指定原生组件的层级

      07-10
      回复
  • 黄河
    黄河
    07-10

    微信版本bug,要么更新微信,要么降低基础库版本!

    07-10
    赞同
    回复
  • Wang
    Wang
    07-15

    这个在低版本中是微信的bug,只能高版本支持

    07-15
    赞同
    回复