收藏
回答

navigationStyle单页面设置兼容性问题

问题模块 框架类型 问题类型 API/组件名称 终端类型 微信版本 基础库版本
API和组件 小程序 Bug navigationStyle 工具 6.6.3 2.6.1

- 当前 Bug 的表现(可附上截图)

文档里说页面设置胶囊模式微信客户端的版本要大于7.0.0

微信开发者工具里模拟的6.6.3 也是可以变成胶囊的




- 预期表现

修改官方文档  确定按照基础库来说明兼容性   我们根据基础库来判断是否兼容

- 复现路径


- 提供一个最简复现 Demo


最后一次编辑于  02-27  (未经腾讯允许,不得转载)
邀请回答
复制链接收藏投诉关注问题回答

3 个回答

  • 连胜
    连胜
    03-01

    官方文档有些地方用的微信客户端版本,确实让人感觉,是不是文档写错了???



    因为大部分都是用基础库版本来判断


    所以,有时间判断兼容性,有点儿怀疑自己写错了~ 其实是文档上就这样写的......


    03-01
    赞同 1
    回复
  • 照明胧
    照明胧
    02-27

    为什么不把所有的兼容性条件都改成最低支持基础库版本号

    改成版本号  我可以修改开发者工具的基础库来模拟

    你给微信版本 我最终还是修改基础库来模拟


    02-27
    赞同
    回复
  • nickname
    nickname
    02-27

    你好,这个请以文档以及真机为准

    02-27
    赞同
    回复 3