收藏
回答

createSelectorQuery方法与其最低版本库不匹配

框架类型 问题类型 API/组件名称 终端类型 微信版本 基础库版本
小程序 Bug createSelectorQuery 客户端 6.6.6 2.0.9

- 当前 Bug 的表现(可附上截图)


- 预期表现


- 复现路径


- 提供一个最简复现 Demo


wx.createSelectorQuery该方法最低可使用的版本库是2.2.3;而并非文档所说的1.4.0版本,2.2.2及以下版本使用会报错,未做兼容处理会造成小程序页面无法加载!
请官方人员及时改正,最好能告知使用这个后的兼容处理方法,目前设置了运行库2.2.3解决的,有没有比较好一点的办法

回答关注问题邀请回答
收藏

1 个回答

  • 社区技术运营专员-小柿子
    社区技术运营专员-小柿子
    2019-06-21

    报错的基础库截图看下?

    2019-06-21
    赞同
    回复 4
    • C丶xy
      C丶xy
      2019-06-25

      2.2.3以下都不行,我试了

      2019-06-25
      回复
    • 社区技术运营专员-小柿子
      社区技术运营专员-小柿子
      2019-06-25回复C丶xy

      没复现报错问题

      2019-06-25
      回复
    • C丶xy
      C丶xy
      2019-06-25回复社区技术运营专员-小柿子



      2019-06-25
      回复
    • C丶xy
      C丶xy
      2019-06-25回复社区技术运营专员-小柿子


      这个函数单独放确实没问题,2.2.3和2.2.2及以下就会报错,可能是用了2.2.3之后才有的组件或者api;刚才去看了一下2.2.3基础库的更新实在是找不出来是哪个,但是我去掉了createSelectorQuery()方法页面能出来,不去掉page都不加载,咦!这就比较神奇了.而且必须是把这个方法注释,不让它执行把方法写在那里都不行.


      2019-06-25
      回复
登录 后发表内容