收藏
回答

小程序刚加载时,发现未有请求的官方图片资源,导致白屏

以下是报错信息:

VM1536:1 Failed to load image http://wxsnsdythumb.wxs.qq.com/109/20204/snsvideodownload?m=127e353c0a9bb8ec60aa40e2f94d51df&filekey=3033020101041f301d02016d040253480410127e353c0a9bb8ec60aa40e2f94d51df020204f2040d00000004627466730000000131&hy=SH&storeid=32303139303432343135353431363030306631383661313336666664393337303561333230613030303030303664&bizid=1023

net::ERR_EMPTY_RESPONSE 


在开发者工具中点开链接,在浏览器访问时是这张图:



这个请求的图片为什么会出现? 代码中根本没有请求过这个,,,


只是偶然出现,


导致我加载小程序时出现白屏现象很久, 数据才更新过来


之前都以为是bug,但是重新加载后又好了


想问下,可以怎么解决这个东西呢?

@官方

回答关注问题邀请回答
收藏

2 个回答

  • 物喜己悲
    物喜己悲
    2019-07-17

    请问有解决办法吗  我这里也遇到了这个问题   但是代码里面没有发送请求

    2019-07-17
    赞同
    回复 5
    • 涛々
      涛々
      2019-07-17
      你加载时没有请求服务端吗?
      2019-07-17
      回复
    • 物喜己悲
      物喜己悲
      2019-07-17回复涛々
      没有 我现在是静态页面 没有任何请求 但是小程序自己发送了请求 也是去请求这张图片
      2019-07-17
      回复
    • 涛々
      涛々
      2019-07-17
      嗯,这个有用到广告组件的应该都会去请求吧 我最近是没有碰到白屏的情况了,应该是也没怎么维护之前的项目吧,哈哈 。 我那个是偶尔才触发的,概率不高,也是特定手机型号才会触发
      2019-07-17
      回复
    • 物喜己悲
      物喜己悲
      2019-07-17回复涛々
      我后来把开发工具卸载重装之后就没有了 真是奇怪
      2019-07-17
      回复
    • 涛々
      涛々
      2019-07-17回复物喜己悲
      因为是概率问题,很难碰到,你一千次可能才出现一两次吧,不用纠结哈
      2019-07-17
      回复
  • 晨
    2019-06-17

    图片是广告组件用到的,图片加载失败不会影响小程序后续的加载逻辑。确认下是否是网络不稳定导致?

    2019-06-17
    赞同
    回复 4
    • 涛々
      涛々
      2019-06-17

      但是这个在开发者工具中,就是等这个加载失败后, 报错信息显示在控制台上时,页面才加载出来,之前一直就是卡着,显示白屏



      2019-06-17
      回复
    • 涛々
      涛々
      2019-06-17回复涛々

      小程序会一直等着这个加载完,才会继续执行正常的业务逻辑

      2019-06-17
      回复
    • 晨
      2019-06-17

      有可以复现的代码片段吗?

      2019-06-17
      回复
    • 涛々
      涛々
      2019-06-17回复

      没有。。。

      宝宝涂色涂鸦画画  wxadb992fe8b696075

      这个是线上的,

      好像问题都是出现在苹果手机上 6 和 7P机型有出现过,

      但是不确定是不是这个问题导致的

      2019-06-17
      回复
登录 后发表内容