收藏
回答

npm 构建错误


按流程引入,npm构建失败报错

最后一次编辑于  2018-08-30  (未经腾讯允许,不得转载)
回答关注问题邀请回答
收藏

2 个回答

  • June
    June
    2018-08-30

    请提供一下你安装的 npm 包名。

    2018-08-30
    赞同
    回复 13
    • 平凡
      平凡
      2018-08-30

      sm-crypto 、 recycle-view

      2018-08-30
      回复
    • June
      June
      2018-08-30回复平凡

      我这边试了下这两个包都能正常构建呢,你是用的哪个平台哪个版本的工具?尝试一下更新到最新的beta版行不?

      2018-08-30
      回复
    • 平凡
      平凡
      2018-08-30

      就是用beta版本额

      2018-08-30
      回复
    • June
      June
      2018-08-30回复平凡

      看截图是mac上是吧,版本号是?

      2018-08-30
      回复
    • 平凡
      平凡
      2018-08-30回复June

      平台 mac  开发者工具是 beta版 基础库 2.2.4

      2018-08-30
      回复
    查看更多(8)
  • 惠雨
    惠雨
    08-14

    win10 x64机器,小程序开发工具版本v1.02.1908132

    在小程序根目录下,已经装好了需要的npm包。

    此时小程序构建就报如下图错,很不友好啊。仍在探索中。。。

    需要require的包:audio-decode

    重现步骤:

    1.在小程序根目录下初始化package.json

    $ npm init


    2.安装依赖的包audio-decode

    $ npm install audio-decode


    3. 小程序开发工具中进行构建:工具->npm构建。报错如图所示


    08-14
    赞同
    回复