收藏
回答

app.js引入tensorflow的 “@tensorflow/tfjs” 联合包时报错

问题类型 插件 AppID 插件版本号 AppID 微信版本 基础库版本
Bug wx6afed118d9e81df9 0.1.0 wx0c5cb2888341798a 微信开发者工具 v1.03.2010240 2.13.2

// app.json

"tfjsPlugin": {

      "version": "0.1.0",

      "provider": "wx6afed118d9e81df9"

    }


// package.json

"dependencies": {

    "@tensorflow-models/speech-commands": "^0.4.2",

    "@tensorflow/tfjs": "^2.0.1",

    "fetch-wechat": "0.0.3"

  }


// app.js

var tf = require('@tensorflow/tfjs');


// 运行报错

Cannot delete property 'toString' of function () { [native code] }

猜测与 “跳过ES6转ES5处理没有关系,因为我自己把代码转到ES5也还是报同样错,难道是用到ES6特性了?

不用分包是因为'@tensorflow-models/speech-commands'这个模型引入时提示需要@tensorflow/tfjs.js


求解答!!!

回答关注问题邀请回答
收藏

1 个回答

  • 圣殿骑士
    圣殿骑士
    11-08

    emmm。。。试试看后台直接引入。。。小程序后台-->设置-->第三方设置-->插件

    11-08
    有用
    回复 1
    • 刘勇
      刘勇
      11-08
      这个添加过了,这是第一步呀
      11-08
      回复
登录 后发表内容
问题标签