收藏
回答

小程序引用插件报错

问题模块 问题类型 插件 AppID 插件版本号 AppID 微信版本 基础库版本
插件 Bug wx45f4822bb96bf08e 1.0.1 wx89f2c50230ef1f89 7.0.0 2.4.3

- 当前 Bug 的表现(可附上截图)


- 预期表现

可以正常引用插件

- 复现路径

只要在app.json中引用插件,就会报错

   "plugins": {

    "myPlugin": {

      "version": "1.0.1",

      "provider": "wx45f4822bb96bf08e"

    }

  }

- 提供一个最简复现 Demo

   "plugins": {

    "myPlugin": {

      "version": "1.0.1",

      "provider": "wx45f4822bb96bf08e"

    }

  }


最后一次编辑于  2018-12-27  (未经腾讯允许,不得转载)
邀请回答
复制链接收藏投诉关注问题回答

4 个回答

  • 娇华
    娇华
    2018-12-27

    麻烦给个相关的代码片段(https://developers.weixin.qq.com/miniprogram/dev/devtools/minicode.html),是哪个开发工具版本呢?

    2018-12-27
    赞同
    回复
  • Richard
    Richard
    2018-12-27

    代码片段:https://developers.weixin.qq.com/s/fshxzYmZ7X4l

    开发工具版本:1.02.1812180

    2018-12-27
    赞同
    回复
  • Seven
    Seven
    2018-12-28

    跟我遇到的情况一样,真机测试没有问题,开发者工具有问题,要把plugn.json里面的publicComponents和pages填写完整。

    我之前漏写了pages。

    {

    "publicComponents": {

    "wishPreview": "components/preview/index"

    },

    "pages": {

    "index": "pages/index"

    },

    "main": "index.js"

    }


    2018-12-28
    赞同
    回复
  • 信林子
    信林子
    01-02

    同问,在本地开发插件的时候没有任何问题,上传到线上,重新引入线上的插件就会报这个错误

    01-02
    赞同
    回复