收藏
回答

编译bug

问题模块 框架类型 问题类型 操作系统 工具版本
开发者工具 小程序 Bug Windows 1.02.1808300


经常出现这种问题,实际上这个文件存在而且没有任何问题。非要打开这个文件,改动一下(随便回车一下,加个空格什么的),才能编译通过。而且这问题不是必现的,编译不通过的文件也是随机的。



最后一次编辑于  2018-09-06  (未经腾讯允许,不得转载)
邀请回答
复制链接收藏关注问题回答

12 个回答

  • nickname
    nickname
    2018-09-06

    你好,开发工具版本是1.02.1808300?复现频率有多高呢?

    2018-09-06
    赞同
    回复 11
    • 胡七筒
      胡七筒
      2018-09-06

      概率比较低,不到十分之一,

      2018-09-06
      赞同
      回复
    • nickname
      nickname
      2018-09-06回复胡七筒

      能否提供一下复现问题的视频或者是GIF图,这边测试没有复现问题

      2018-09-06
      赞同
      回复
    • 龙哥呼弟
      龙哥呼弟
      2018-09-06回复nickname

      我也是更新了8.30的版本后编译文件报这个错,但我是固定的文件下的js。我排查了下原因,是因为引用了同一个组件的问题,这个组件本身没有什么问题,但是我引用了就有问题,组件是vant-weapp


      上传代码也可以 就是工具报错,我把page里错误的文件删了 再一个个放进去 就好了,只要不关闭工具就正常运行,关闭工具再重新打开,还是会报上面的错。

      但是同样的包我同事打开就没事,也是最新的版本。希望官网可以早点修复这个问题


      2018-09-06
      赞同
      回复
    • nickname
      nickname
      2018-09-06回复龙哥呼弟

      你参考以下帖子处理一下看能不能解决问题:

      v1.02.1808300 WIN工具编译代码报错
      https://developers.weixin.qq.com/community/develop/doc/000268e2ecc81062b347b3ceb5c000


      2018-09-06
      赞同
      回复
    • 龙哥呼弟
      龙哥呼弟
      2018-09-06回复nickname

      这个帖子也没有解决

      2018-09-06
      赞同
      回复
    查看更多(6)