收藏
回答

微信小程序 websocket 安卓(版本4.4.4) 小米3 连接 错误

问题模块 框架类型 问题类型 API/组件名称 终端类型 微信版本 基础库版本
API和组件 小程序 Bug wx.websocket 客户端 6.7.2 2.0.0

微信小程序 websocket 安卓(版本4.4.4) 小米3 连接 错误 


报错信息如下

com.android.org.bouncycastle.jce.exception.ExtCertPathValidatorException: Could not validate certificate: null


安卓 小米3 老手机,新手机可以正常连接


wx.socket 是否,可以设置  SNI

自动选择SSL 证书


wss地址

wss://devapi.baiwandz.com



最后一次编辑于  2018-08-20  (未经腾讯允许,不得转载)
邀请回答
复制链接收藏关注问题回答

7 个回答

  • 不再让梦枯萎
    不再让梦枯萎
    2018-08-20

    基础库版本 版本,应该是 2.0.0以上版本,还有乐视的 x900也是出现类似的问题




    2018-08-20
    赞同
    回复 1
    • 照明胧
      照明胧
      2018-11-25

      请问有解决办法了吗

      2018-11-25
      赞同
      回复
  • 是柿子啊
    是柿子啊
    2018-08-22

    你好,请提供一下出现问题的机型和微信版本,以及能复现问题的简单代码片段(https://developers.weixin.qq.com/miniprogram/dev/devtools/minicode.html)。

    2018-08-22
    赞同
    回复 3
    • 照明胧
      照明胧
      2018-11-25

      这个帖子的问题有解决吗


      2018-11-25
      赞同
      回复
    • 周希
      周希
      2018-11-28

      同问,现在碰到这个问题,影响蛮大,并且在论坛里搜到关于这个问题全部没有答案

      2018-11-28
      赞同
      回复
    • 周希
      周希
      2018-11-28

      可以加微信看下这个问题么?

      2018-11-28
      赞同
      回复
  • 周希
    周希
    2018-11-28

    同问,现在碰到这个问题,影响蛮大,并且在论坛里搜到关于这个问题全部没有答案

    2018-11-28
    赞同
    回复