收藏
回答

动态配置json中的enablePullDownRefresh属性

问题模块 框架类型 问题类型 API/组件名称 终端类型 微信版本 基础库版本
API和组件 小程序 需求 enablePullDownRefresh 工具 6.7.3 2.0.0

- 解决scroll-view下滑和页面下拉刷新冲突的情况,一般自定义下拉选择框都会用到scroll-view做封装,但是如果页面需要下拉刷新,这两个事件就会冲突


- 态配置json中的enablePullDownRefresh属性


最后一次编辑于  2018-12-11
回答关注问题邀请回答
收藏

2 个回答

  • 清粥小菜
    清粥小菜
    2018-12-18

    我也遇到这种情况  我的model弹出   讲道理不能下拉了   科室还是触发了下拉事件   无法阻止。真是很苦恼

    2018-12-18
    赞同
    回复
  • 韬々
    韬々
    2018-12-11

    没太明白是什么样的需求。如果这个页面不希望下拉刷新的话直接禁用该属性就可以了。

    2018-12-11
    赞同
    回复 1
    • Json
      Json
      2018-12-11

      需求就是我的组件被调用的时候,禁止页面下拉刷新,调用组件完毕后开启页面下拉刷新,就好像我在有下拉刷新的页面中调用官方的picker组件一样,picker组件的滑动和页面的下拉刷新事件冲突了,这时候我需要在我的picker组件被调用的时候就可以动态禁止页面的下拉刷新效果。以保证他们事件不冲突

      2018-12-11
      回复