收藏
回答

this.selectComponent is not a function错误

问题模块 框架类型 问题类型 API/组件名称 终端类型 微信版本 基础库版本
API和组件 小程序 Bug 自定义组件info 客户端 6.5.12 2.0.0


有没有遇到这个微信版本报错的,这种错误怎么解决?

- 当前 Bug 的表现(可附上截图)


- 预期表现


- 复现路径


- 提供一个最简复现 Demo


最后一次编辑于  2018-09-30  (未经腾讯允许,不得转载)
邀请回答
复制链接收藏投诉关注问题回答

3 个回答

  • 左明James
    左明James
    2018-10-02

    {

        "usingComponents": {

        }

    }

    解决了, .json 文件里加上这个配置才有 selectComponent 方法


    2018-10-02
    赞同 1
    回复
  • 娇华
    娇华
    2018-09-30

    你好,这里需要选择1.6.8以上的基础库哟

    2018-09-30
    赞同
    回复 3
    • running
      running
      2018-09-30

      基础库我用的是2.0.0的

      2018-09-30
      回复
    • 娇华
      娇华
      2018-09-30回复running

      这个客户端版本对应的就不是啦https://developers.weixin.qq.com/miniprogram/dev/framework/client-lib/client.html

      2018-09-30
      回复
    • running
      running
      2018-09-30回复娇华

      什么意思不太懂,是要在后台设置最低基础库吗,微信6.5.12版本的用户的基础库低于1.6.8,所以会报错,设置最低基础库低于1.6.8的升级最新微信版本

      2018-09-30
      回复
  • coder2017
    coder2017
    2018-10-17

    .json文件的格式不对也会导致这个问题。

    正确的格式内容如下:


    {  "usingComponents": {    "pwddialog":"../components/pwddialog/pwddialog"  }

    }


    2018-10-17
    赞同
    回复