收藏
回答

新版本的开发工具,编译过不去??? @官方

问题模块 框架类型 问题类型 操作系统 工具版本
开发者工具 小程序 Bug Windows V1.02.1809111

升级新版本的编译工具后,项目直接编译报错,装回以前的版本,编译就可以过(备注:新版本手机预览,也可以运行项目,就是用模拟器,编译过不去),如图:





最后一次编辑于  2018-09-25  (未经腾讯允许,不得转载)
邀请回答
复制链接收藏关注问题回答

5 个回答

  • 林超
    林超
    2018-09-25

    直接点击堆栈看下错误信息是什么?


    确认下是否是基础库的 api 变更或者其他导致的



    2018-09-25
    赞同
    回复 1
    • 小羊
      小羊
      2018-09-25

      报错和上个版本报错一样(前面一个版本,我也是用不了,查了很久,都没查出来是哪的问题,最后装回老版本,好了...),说是我一个js工具类引用有问题,我用的相对路径,用手机预览和以前的老版本都是没有问题的,现版本引用这个js工具类,调用不到里面对外开放的方法

      2018-09-25
      赞同
      回复
  • 小羊
    小羊
    2018-09-25

    我知道是什么问题了,我的A.js文件引用B.js文件,然后再B.js中,也有对A.js的引用,这种情况下,编译就过不去,这是新加的规则,还是后期可以优化的? @林超  @官方

    2018-09-25
    赞同
    回复
  • 海宏
    海宏
    2018-09-25

    死循环了,肯定编译不了啊

    2018-09-25
    赞同
    回复 1
    • 小羊
      小羊
      2018-09-25

      以前的开发环境是没有问题的,新版本才出的问题,更新内容也没看到加有这个限制。

      2018-09-25
      赞同
      回复