收藏
回答

小程序启动时 app-service 的 flushCacheData 白屏?

问题模块 框架类型 问题类型 终端类型 微信版本 基础库版本
框架 小程序 Bug 微信iOS客户端 7.0.5 2.6.1

问题表现

部分用户反馈小程序打开白屏。


具体的报错信息如下:

TypeError
line:1109,column:1675,TypeError: t.default.log is not a function. (In 't.default.log(e)', 't.default.log' is undefined) Stack:clearStorage@https://usr/app-service.js:1109:1675
flushCacheData@https://usr/app-service.js:1109:1881
initNameSpace@https://usr/app-service.js:1109:642
https://usr/app-service.js:1109:1946
h@https://lib/WASubContext.js:1:1399168
https://lib/WASubContext.js:1:1398477。
 
https://usr/app-service.js:1106:119
h@https://lib/WASubContext.js:1:1399168
https://lib/WASubContext.js:1:1398477
https://usr/app-service.js:1112:27
h@https://lib/WASubContext.js:1:1399168
https://usr/app-service.js:1113:17
f@https://lib/WASubContext.js:1:1398590
requirePlugin@https://lib/WASubContext.js:1:1399891
global code@https://usr/app-service.js:1122:15
evaluateScriptFile@https://lib/WAService.js:1:12367
value@https://lib/WAService.js:1:111948
https://lib/WAService.js:1:113659
https://lib/WAService.js:1:109420
https://lib/WAService.js:1:119884
https://lib/WAService.js:1:118868
https://lib/WAService.js:1:118832
https://lib/WAService.js:1:119884
m@https://lib/WAService.js:1:1906



一些情况:

  1. 最近越来越频繁收到一些用户反馈,说我司的小程序打开白屏,但是能测试到的手机都表现正常。直到最近发了个新的版本,问题出现在我自己的手机上(iPhone XS Max + iOS 12.4.1 + 微信 7.0.5);

  2. 后台的反馈数据:这个问题集中在 iOS 上,几乎都是最新版的微信(7.0 以上) + 最新版的 iOS (iOS 12 以上) + 小程序基础库 2.8.0、2.8.1、2.8.2;

  3. 用户反馈的问题都集中在发了一个版本之后;

  4. 自己的手机白屏后,抓报错,看到方法名 `flushCacheData()`,感觉是缓存之类的问题。首先想通过“设置-切换帐号”的方式“清楚缓存”(一直这么干),无效。折腾半天,删除、重新安装微信,一切恢复正常;

  5. 这个 `flushCacheData()` 和之中的 'clearStorage()' 在项目代码里并不存在,是不是小程序启动时的什么机制?

  6. 问题集中发生时候,开发似乎在 IDE 的 nightly build 和 stable 两个版本之间切换,通过不同版本的 IDE 提交发布项目,可能是这个导致的么?

  7. 相关小程序 AppID:wx0af94baf8d365fd0。


目前后台收集到的报错:



有任何可以尝试解决的办法么?


最后一次编辑于  09-18
回答关注问题邀请回答
收藏

2 个回答

  • |G.XIAO|
    |G.XIAO|
    09-25

    没有遇到这个的问题,通过稳定版的开发工具打个码验证下,是不是能快速fix这个问题

    09-25
    赞同
    回复
  • 皮皮
    皮皮
    09-25

    也出现了白屏(从主包进入分包),手机预览线上才会出现问题。打开调试后发现报错, module xxx.js is not defined Stack:require@https://lib/WASubContext.js ...

    09-25
    赞同
    回复
问题标签