收藏
回答

新版本开发工具什么时候支持MAC开发蓝牙?

问题模块 框架类型 问题类型 API/组件名称 终端类型 微信版本 基础库版本
API和组件 小程序 Bug wx.openBluetoothAdapter(OBJECT) 工具 6.6.5 1.5.2

- 当前 Bug 的表现(可附上截图)


- 预期表现

老版本  0.22 是可以正常再MAC上进行开发的蓝牙功能,再新版本上一直都无法使用。


这功能已经半年都没有修复了,我都想直接投诉了。


现在腾讯云不支持老版本的 方案,必须用新方案,但新方案老调试工具又用不了。真心心累。


现在必须每次调试都要用手机来进行,实在没有效率。


- 复现路径

    随意生成一个新项目,直接调用就会出错。

    MAC 版本

- 提供一个最简复现 Demo

直接调用就出错!

wx.openBluetoothAdapter({
  success: function (res) {    console.log(res)
  }
})


最后一次编辑于  2018-03-28  (未经腾讯允许,不得转载)
回答关注问题邀请回答
收藏

4 个回答

  • 欧元
    欧元
    2018-04-19

    支付宝现在都是可以直接用MACbook 今天调试蓝牙的,就微信自己在开倒车!

    2018-04-19
    赞同
    回复
  • 欧元
    欧元
    2018-04-11

    我想知道 新版本的开发工具 支持 MACbook 开发很难?  还是 不支持 压根做不了?

    2018-04-11
    赞同
    回复
  • 欧元
    欧元
    2018-04-11

    主要是MACbook 版本调试 如果能直接调会便捷很多,节省很多时间,因为会出现连续多次进行测试的情况,每次都用手机就特别痛苦了。


    2018-04-11
    赞同
    回复
  • 包磊 Baolei
    包磊 Baolei
    2018-03-29

    小程序是运行在手机上的,什么时候能够运行在MAC上了,支持了才有意义吧?

    2018-03-29
    赞同
    回复