收藏
回答

自己的服务TLS版本大于等于1.2,为什么开发工具一直提示错误

问题模块 框架类型 操作系统 工具版本
开发者工具 小程序 Windows v1.02.180315

自己的服务TLS版本大于等于1.2,为什么开发工具一直提示错误


本人服务器TLS1.2。1.1。1.0都支持

最后一次编辑于  2018-03-20  (未经腾讯允许,不得转载)
邀请回答
复制链接收藏投诉关注问题回答

2 个回答

  • Goldman
    Goldman
    2018-03-20

    我遇到同样的现象,实际跟服务器没关系。


    我服务器也是支持TLS1.2的,直接wx.request提交表单没问题。

    但是,如果先调用过wx.uploadFile,再调用wx.request,同样的一个请求,就会报错,提示对应的服务器 TLS 为 undefined”。

    我用的代码以前在旧版的开发者工具里都是调好的,现网都在正常跑,这几天更新了开发者工具,代码没动就出这个问题了,怀疑是新版开发者工具的Bug!

    2018-03-20
    赞同
    回复
  • Goldman
    Goldman
    2018-03-20

    其他人也问了,确定是开发者工具的Bug,解决方法如下。




    2018-03-20
    赞同
    回复