收藏
回答

低版本可以用 __wxWebviewI 兼容 getPageId 吗?

目前观察到 getPageId 取到的是 __wxWebviewId__,组件和组件所在页面的 __wxWebviewId__ 是一样的

所以:

  • __wxWebviewId__ 一定会有吗?
  • 组件和组件所在页面的 __wxWebviewId__ 一定是一样的吗?
  • 低版本可以用 __wxWebviewI 兼容 getPageId 吗?


回答关注问题邀请回答
收藏

1 个回答

  • 小程序技术专员-binnie
    小程序技术专员-binnie
    03-31

    建议用getPageId判断

    03-31
    有用
    回复 5
    • 树
      03-31
      低版本咋整啊?
      03-31
      回复
    • 小程序技术专员-binnie
      小程序技术专员-binnie
      03-31回复
      这个是2.7.1才支持的,可以配置小程序的最低版本的基础库
      03-31
      回复
    • 树
      04-01
      因为会损失一部分用户,所以基础库升不了🥺。


      我看低版本也是有 __wxWebviewId__ 的,使用 __wxWebviewId__ 有什么风险吗?
      04-01
      回复
    • 小程序技术专员-binnie
      小程序技术专员-binnie
      04-01回复
      这种没有对外的我们这边不保证一直可用的
      04-01
      回复
    • 树
      04-01
      好的🙏
      04-01
      回复
登录 后发表内容
问题标签