收藏
回答

行内style样式在最新版开发者工具出现at-rule or selector expected?

前几天我手抖,升级了微信开发者工具到最新版,也就是1.03.2005140这个版本(win10 64位电脑)。今天我再打开编辑器发现一个有趣的现象,若组件中有行内样式且设置动态值的化为就出现:at-rule or selector expected 的报错。

比如:

<view style="top:{{topValue}}">这个在1.03.2005140版本就会报错,在未升级前不会报错</view>
<view class="box {{isShow === true ? 'active' : ''}}">这个不报错</view>

如图:



在社区搜索,我发现在5月28号时就有人提出过此问题,原帖子地址:https://developers.weixin.qq.com/community/develop/doc/00066c42dd4a602fa86a2a4ab5bc00?highline=at-rule%20or%20selector%20expected

社区管理提供的截图中,微信小程序开发者工具版本与我的不同,麻烦社区管理和技术团队核实下问题,谢谢。

回答关注问题邀请回答
收藏

3 个回答

  • 社区技术运营专员-CJiang
    社区技术运营专员-CJiang
    06-18

    请提供能复现问题的简单代码片段(https://developers.weixin.qq.com/miniprogram/dev/devtools/minicode.html)。

    06-18
    有用 2
    回复
  • A000韟邇坣-
    A000韟邇坣-
    星期二 10:01

    右下角铃铛旁边语言换成XML,你的可能是HTML

    星期二 10:01
    有用
    回复
  • 王志鹏
    王志鹏
    06-18

    我都是一个版本用到老 最好不要更新 每次新的开发工具出来都是一大推BUG

    左上角菜单上有微信开发工具 可以回退版本

    06-18
    有用
    回复 1
    • 流年
      流年
      06-18
      谢谢回复哈,[:笑哭][:笑哭][:笑哭] ,来自过来人的忠告,哈哈哈哈哈
      06-18
      回复
登录 后发表内容
问题标签