收藏
回答

开发者工具首次打开提示:TypeError: undefined is not iterable?

TypeError: undefined is not iterable (cannot read property Symbol(Symbol.iterator))
    at VM42 WAService.js:1
    at r (VM42 WAService.js:1)
    at a.value (VM42 WAService.js:1)
    at VM42 WAService.js:1
    at r (VM42 WAService.js:1)
    at VM42 WAService.js:1
    at VM42 WAService.js:1
    at n (VM40 asdebug.js:1)
    at e.exports.<anonymous> (VM40 asdebug.js:1)
    at VM40 asdebug.js:1


回答关注问题邀请回答
收藏

11 个回答

  • SteveAndy
    SteveAndy
    2020-03-10

    我也遇到了这个问题,尝试更改调试基础库换成最新后,情况消失;

    开发者工具:详情(右上方)-》本地设置-》调试基础库(换成最新版本即可)

    2020-03-10
    有用 4
    回复
  • 小程序商城定制开发2600元全包
    小程序商城定制开发2600元全包
    05-25

    基础库的版本换一下吧

    05-25
    有用 1
    回复
  • 东
    2020-03-30
    好像确实是和基础库的版本有关
    2020-03-30
    有用 1
    回复
  • Why not?
    Why not?
    2020-03-14

    开发工具中调试,基础库2.10.3报这个错,2.10.2正常,所以怀疑是2.10.3基础库有问题

    2020-03-14
    有用 1
    回复 1
    • cc🌸
      cc🌸
      2020-06-03
      一样,再往上的版本也是不行的
      2020-06-03
      回复
  • awow
    awow
    2019-12-10

    更新到v1.02.1912062版本后页面跳转时会遇到文中所述报错,编译多几次后面就没遇到过报错了

    2019-12-10
    有用 1
    回复
  • 可乐
    可乐
    2020-04-23

    我也遇到了同样的问题,早上还好好的,更新新版本后运行出现的

    下面捕捉到的报错地方,麻烦官方排查一下

    2020-04-23
    有用
    回复 3
    • 可乐
      可乐
      2020-04-23
      还有个问题在
      2020-04-23
      回复
    • 林yy
      林yy
      2020-04-24
      我也遇到了,还以为是我代码有问题
      2020-04-24
      回复
    • 可乐
      可乐
      2020-04-24回复林yy
      真巧
      2020-04-24
      回复
  • 用梦想拴住远方的地平线
    用梦想拴住远方的地平线
    2020-04-15

    我也经常遇到,开发工具版本是最新的

    2020-04-15
    有用
    回复
  • Bruce_涛涛
    Bruce_涛涛
    2020-02-22

    这个问题解决了吗,我第一次编译没问题。点重新编译 就一堆这样的报错

    2020-02-22
    有用
    回复
  • John zzp
    John zzp
    2019-12-09

    刚刚也遇到这个问题,但是更新工具是前几周就更新的,对于内容没什么影响,就是报这个错,刷新就消失了

    2019-12-09
    有用
    回复
  • Aranoch 🍑
    Aranoch 🍑
    2019-12-09

    今天更新到v1.02.1912062版本后也遇到这个问题,刷新后就没了

    2019-12-09
    有用
    回复

正在加载...

登录 后发表内容
问题标签